CFD Online Discussion Forums

CFD Online Discussion Forums (
-   OpenFOAM Running, Solving & CFD (
-   -   Axisymmetric solidDisplacementFoam Run (

Hisham September 21, 2011 11:06

Axisymmetric solidDisplacementFoam Run
2 Attachment(s)
Hi Foamers,

I did a very simple axisymmetric run with solidDisplacementFoam. The mesh was generated in Gmsh. I got very strange output: The axis (left) has an X-displacement value???? This is not OK. I attach the files and an image. If you know something about it, please tell me what I did wrong?

Best regards,
Hisham El Safti

Hisham September 21, 2011 12:41

I found I left the planeStress switch on. I turned it off but still the same behaviour.

Any clue???

Hisham September 21, 2011 15:47

The problem does not exist using blockMesh

I guess with Gmsh the problem is how to define the axis as an empty BC (among other errors in my boundary & D/T files)

I'll post here if I found how to do it with Gmsh

Hisham September 22, 2011 05:55

I got it to do it as expected thanks to another post by elorriaux: in this thread



i suppose you have followed the wiki instructions and checked the different constraints :

As you have already your model in gmsh, you can directly revolve your mesh in gmsh :

- rotate -2.5 your plane from your main 2D plane
- extrude (revolve) 5
- save mesh
- gmshToFoam

I've already done that with gmsh, it works fine.

You can also have another solution by revolving your mesh in OpenFoam with the extrudeMesh tool, but it's not the easier way to do, i think.

Good luck.
Problem solved, now the X disp is zero at the axis as expected :)

All times are GMT -4. The time now is 16:14.