CFD Online Discussion Forums

CFD Online Discussion Forums (
-   OpenFOAM Running, Solving & CFD (
-   -   Bananas!!! error in GGI and GAMG (

waku2005 November 14, 2011 05:33

Bananas!!! error in GGI and GAMG
Dear all,

I simulated 3-D vertical wind turbine rotors using pimpleDyMFoam with GGI on OF1.6-ext (latest Git ver.).
Some cases worked fine but another case failed with FATAL error message like below at p iteration stage which uses GAMG solver.
In this error message, what "bananas!!!" means ?

Thanks in advance,

---- error -----
[waku@ensis11 pimpleDyMFoam_VAWT2_NACA0018]$ pimpleDyMFoam
[snip: FOAM headers]
Create time

Create dynamic mesh for time = 0

Selecting dynamicFvMesh mixerGgiFvMesh
Initializing the GGI interpolator between master/shadow patches: statorInterface/rotorInterface
void mixerGgiFvMesh::addZonesAndModifiers() : Zones and modifiers already present. Skipping.
Mixer mesh:
origin: (0 0 1)
axis : (0 0 1)
rpm : -191
Reading field p

Reading field U

Reading/calculating face flux field phi

Selecting incompressible transport model Newtonian
Selecting turbulence model type RASModel
Selecting RAS turbulence model kOmegaSST
alphaK1 0.85034;
alphaK2 1;
alphaOmega1 0.5;
alphaOmega2 0.85616;
gamma1 0.5532;
gamma2 0.4403;
beta1 0.075;
beta2 0.0828;
betaStar 0.09;
a1 0.31;
c1 10;

Reading field rAU if present

Starting time loop

Courant Number mean: 0 max: 0.0365714 velocity magnitude: 5
Time = 5e-05

DILUPBiCG: Solving for Ux, Initial residual = 1, Final residual = 7.55501e-06, No Iterations 1
DILUPBiCG: Solving for Uy, Initial residual = 1, Final residual = 9.75065e-08, No Iterations 3
DILUPBiCG: Solving for Uz, Initial residual = 1, Final residual = 1.70441e-06, No Iterations 1


From function ggiGAMGInterfaceField::updateInterfaceMatrix
in file matrices/lduMatrix/solvers/GAMG/interfaceFields/ggiGAMGInterfaceField/ggiGAMGInterfaceField.C at line 113.

FOAM aborting

psosnows November 14, 2011 06:40

This should clear the problem ;)
Good luck!

akidess November 14, 2011 07:46

Pawel, I had the same though reading the thread title, but this error is unrelated in my opinion.

The offending piece of code is:

110    // New treatment.  HJ, 26/Jun/2011
111    if (zonePnf.size() != faceCells.size())
112    {
113        FatalErrorIn("ggiGAMGInterfaceField::updateInterfaceMatrix")
114            << "Bananas!!!"
115            << abort(FatalError);
116    }

waku2005 November 14, 2011 10:21

Thanks Anton and Pawel

I know the banana method mentioned by Pawel.
Anton's comment gives me useful suggestions.
I'll check my mesh.

Best regards

waku2005 November 15, 2011 04:50

Dear all,

I checked my mesh but no error was found in my data with checkMesh command,
however, I found zonePf.size() had non zero value even faceCell.size() was zero
during p calculation stage of the below if statement.

Does the way of GGI come to include something new after jun/2011 update ?
Any suggestions are highly welcomed.


// New treatment. HJ, 26/Jun/2011
111 if (zonePnf.size() != faceCells.size())
112 {
113 FatalErrorIn("ggiGAMGInterfaceField::updateInterfa ceMatrix")
114 << "Bananas!!!"
115 << abort(FatalError);
116 }

smajer November 17, 2011 16:01

Hi waku2005,

I've had a same problem several weeks ago, and I solved it by replacing GAMG solver for p with PCG. After few iterations I replaced it again with GAMG and after that everything worked just fine. I cannot explain the reason for this behavior, but it worked for me.



waku2005 November 17, 2011 18:41

Dear Sinisa

Thanks a lot !
I've just replace GAMG to PCG solver for a workaround.
I'll do the same with your suggestion.


waku2005 November 21, 2011 23:22

Dear Sinisa

Sorry to my late response.
I've just test PCG solver for several time steps from startTime,
and then changed to the pressure solver to GAMG but failed to continue my run with the same "Bananas!" error.


smajer November 22, 2011 06:47

Sorry,but I have no idea where is the problem. This worked for me and I didn't try to find out why.
Perhaps you should iterate more time steps with PCG (but this looks like a 'blind man's attempt').


waku2005 November 22, 2011 07:26

Thanks a lot!
I'll continue to find where is the problem.


at 24/11/2011
I've just found that the parallel run with GAMG solver works !

All times are GMT -4. The time now is 13:28.