CFD Online Discussion Forums

CFD Online Discussion Forums (
-   OpenFOAM Running, Solving & CFD (
-   -   Problems running Smagorinsky Model in XiFoam or dieselFoam (

MMK December 22, 2011 07:52

Problems running Smagorinsky Model in XiFoam or dieselFoam
Hi Foamers,
I am new to OpenFoam and I am trying to run a simple LES case with smagorinsky Model. I setup a case for dieselFoam solver with LES model. This case works with the
oneEqEddy model but it doesnot work with smagorinsky Model. I even tried to run the LES tutorial case of XiFoam with Smagorinsky Model but it gave the same kind of error. Please can someone elaborate the problem. :confused:

Erro looks like this

Evolving Spray
Solving chemistry
#0 Foam::error::printStack(Foam::Ostream&) in "/opt/openfoam171/lib/linux64GccDPOpt/"
#1 Foam::sigFpe::sigFpeHandler(int) in "/opt/openfoam171/lib/linux64GccDPOpt/"
#2 in "/lib/"
#3 Foam::divide(Foam::Field<double>&, Foam::UList<double> const&, Foam::UList<double> const&) in "/opt/openfoam171/lib/linux64GccDPOpt/"
#4 void Foam::divide<Foam::fvPatchField, Foam::volMesh>(Foam::GeometricField<double, Foam::fvPatchField, Foam::volMesh>&, Foam::GeometricField<double, Foam::fvPatchField, Foam::volMesh> const&, Foam::GeometricField<double, Foam::fvPatchField, Foam::volMesh> const&) in "/home/uid27768/OpenFOAM/uid27768-1.7.1/applications/bin/linux64GccDPOpt/MydieselFoam"
#5 Foam::tmp<Foam::GeometricField<double, Foam::fvPatchField, Foam::volMesh> > Foam::operator/<Foam::fvPatchField, Foam::volMesh>(Foam::tmp<Foam::GeometricField<doub le, Foam::fvPatchField, Foam::volMesh> > const&, Foam::tmp<Foam::GeometricField<double, Foam::fvPatchField, Foam::volMesh> > const&) in "/home/uid27768/OpenFOAM/uid27768-1.7.1/applications/bin/linux64GccDPOpt/MydieselFoam"
in "/home/uid27768/OpenFOAM/uid27768-1.7.1/applications/bin/linux64GccDPOpt/MydieselFoam"
#7 __libc_start_main in "/lib/"
in "/home/uid27768/OpenFOAM/uid27768-1.7.1/applications/bin/linux64GccDPOpt/MydieselFoam"
Floating point exception

jmart7 May 27, 2012 16:31

Hello MMK,

I get the same error you did at the moment. Did you ever figure out a solution to this?

Thanks in advance for any help!

All times are GMT -4. The time now is 03:07.