CFD Online Discussion Forums

CFD Online Discussion Forums (
-   OpenFOAM Running, Solving & CFD (
-   -   Divergence in rhoPimpleDyMFoam (

bvieira March 28, 2012 15:32

Divergence in rhoPimpleDyMFoam
2 Attachment(s)
Hello all!

I put together a solver combining rhoPimpleFoam and PimpleDyMFoam to be able to simulate a pitching airfoil by rotating the entire grid.
After being able to compile everything and run a case with no errors, Iím now facing a convergence problem.

I get an error of number of iterations exceeded:


[0] Maximum number of iterations exceeded
[0]    From function specieThermo<Thermo>::T(scalar f, scalar T0, scalar (specieThermo<Thermo>::*F)(const scalar) const, scalar (specieThermo<Thermo>::*dFdT)(const scalar) const) const

I think my temperature is diverging and then dragging density with it.
My initial conditions are taken from a converged steady-state solution using rhoSimpleFoam.
I tried to play with the under-relaxation factors, as well as the number of inner correctors (nCorrectors), but that doesnít seem to be helping much (runs longer, but still blows up).
Check mesh passes. This grid has also been used in Fluent before.
Also, Iím running with a pretty small timestep, with MaxCo being less than 1.5. I'm currently using 10 subiterations (nOuterCorrectors).

On my solver side, I think everything seems to be working. I have inspected the mesh during rotation, and it seems to be rotating as desired.
Just as a check, I run the same case, without pitching on rhoPimpleFoam, but still transient, and I was getting a similar problem.

Any ideas on what could be going wrong? Any suggestion on more stable schemes perhaps ? Or changes in the relaxations factors?

I'm attaching the fvSolution and the fvSchemes files.
Some of the underrelaxation factors that I've tried are put as comments in the fvSolution file.

I appreciate any inputs.

karkar July 19, 2012 02:22

Hi bvieira,

did you manage to track down your problem?

Could you share your rhoPimpleDyMFoam solver? I currently need that as well and I guess I would be wasting time reinventing a wheel you already made round...

All times are GMT -4. The time now is 20:20.