CFD Online Discussion Forums

CFD Online Discussion Forums (
-   OpenFOAM (
-   -   wired error in openfoam (

conceptone August 5, 2012 20:51

wired error in openfoam
Hi everyone, I'm running the sprayFoam. I have successfully run several cases before, but from last Monday, Openfoam became very wired. It stopped at the beginning and the error report is as below(with sprayFoam):
Time = 1.04768e-05
Solving cloud sprayCloud
#0 Foam::error::printStack(Foam::Ostream&) at /usr/apps1/openfoam-2.1.1/OpenFOAM-2.1.1/src/OSspecific/POSIX/printStack.C:201
#1 Foam::sigSegv::sigHandler(int) at /usr/apps1/openfoam-2.1.1/OpenFOAM-2.1.1/src/OSspecific/POSIX/signals/sigSegv.C:56
#2 __restore_rt at sigaction.c:0
#3 Foam::divideOp3<double, double, double>::operator()(double const&, double const&) const at /usr/apps1/openfoam-2.1.1/OpenFOAM-2.1.1/src/OpenFOAM/lnInclude/ops.H:133
#4 void VectorSpaceOps<3, 0>::opVS<Foam::Vector<double>, Foam::VectorSpace<Foam::Vector<double>, double, 3>, double, Foam::divideOp3<double, double, double> >(Foam::Vector<double>&, Foam::VectorSpace<Foam::Vector<double>, double, 3> const&, double const&, Foam::divideOp3<double, double, double>) at /usr/apps1/openfoam-2.1.1/OpenFOAM-2.1.1/src/OpenFOAM/lnInclude/VectorSpaceM.H:34
#5 Foam::Vector<double> Foam::operator/<Foam::Vector<double>, double, 3>(Foam::VectorSpace<Foam::Vector<double>, double, 3> const&, double) at /usr/apps1/openfoam-2.1.1/OpenFOAM-2.1.1/src/OpenFOAM/lnInclude/VectorSpaceI.H:576
#6 Foam::ReitzKHRT<Foam::SprayCloud<Foam::ReactingClo ud<Foam::ThermoCloud<Foam::KinematicCloud<Foam::Cl oud<Foam::SprayParcel<Foam::ReactingParcel<Foam::T hermoParcel<Foam::KinematicParcel<Foam::particle> > > > > > > > > >::update(double, Foam::Vector<double> const&, double&, double&, double&, double&, double&, double&, double&, double&, double&, double&, double&, double&, double, double, double, double, Foam::Vector<double> const&, Foam::Vector<double> const&, double, double, Foam::Vector<double> const&, double, double, double, double&, double&, Foam::cachedRandom&) const at ~/OpenFOAM/liao23-2.1.1/src/lagrangian/spray/lnInclude/ReitzKHRT.C:132
#7 void Foam::SprayParcel<Foam::ReactingParcel<Foam::Therm oParcel<Foam::KinematicParcel<Foam::particle> > > >::calcBreakup<Foam::ReactingParcel<Foam::ThermoPa rcel<Foam::KinematicParcel<Foam::particle> > >::TrackingData<Foam::SprayCloud<Foam::ReactingClo ud<Foam::ThermoCloud<Foam::KinematicCloud<Foam::Cl oud<Foam::SprayParcel<Foam::ReactingParcel<Foam::T hermoParcel<Foam::KinematicParcel<Foam::particle> > > > > > > > > > >(Foam::ReactingParcel<Foam::ThermoParcel<Foam::Ki nematicParcel<Foam::particle> > >::TrackingData<Foam::SprayCloud<Foam::ReactingClo ud<Foam::ThermoCloud<Foam::KinematicCloud<Foam::Cl oud<Foam::SprayParcel<Foam::ReactingParcel<Foam::T hermoParcel<Foam::KinematicParcel<Foam::particle> > > > > > > > > >&, double, int) at /usr/apps1/openfoam-2.1.1/OpenFOAM-2.1.1/src/lagrangian/spray/lnInclude/SprayParcel.C:254
#16 _start in "/usr/apps1/openfoam-2.1.1/OpenFOAM-2.1.1/platforms/linux64Gcc44DPDebug/bin/sprayFoam"

While if I run with mysprayFoam(no change with solver only link to my library), it also stopped at the beginning and said:
mesh flux field does not exists, is the mesh actually moving?

From function fvMesh::phi()
in file fvMesh/fvMeshGeometry.C at line 400.

FOAM exiting
I believe it's a configuration problem as when I run on my friend's computer(with sprayFoam), it works. So it may not be the input problem or case problem. Thanks for helping.

wyldckat August 6, 2012 00:32

Greetings conceptone,

Well, there are several possibilities, all of which are likely either hardware related or incorrect usage ;)

Starting with the smaller list - incorrect usage:
  • Did you make sure you were running with a clean case?
  • Were all of the necessary files copied to the right place?
  • Did you change anything in OpenFOAM's global "controlDict" files?
  • Did you accidentally erase anything?
Possible hardware issues:
  • Are you running the case in a remote and/or shared folder?
  • Is there enough disk space?
  • Is there enough memory space?
  • Were there any periodic updates made to the system? More importantly, was the kernel updated or any core system libraries have been updated without rebooting?
  • Does the command dmesg give any reports of problems?
  • Are you using a virtual machine?
  • Have you used Adobe Flash for seeing stuff online?
    I ask this in particular because with me, it has lead to memory corruptions... Adobe Flash on Linux is almost a software aberration :rolleyes: :(
  • Have you tried rebooting the machine?
Best regards,

conceptone August 6, 2012 12:06

Dear Bruno,
Thanks for replying. Actually, I submit the case to run on the processor, and the case is not run by my computer and I don't have the manage right for linux system, so ...(sorry for forgetting those terms...)
When you say "clean case", actually I copied a case finished file from the remote file to my memory file last week, and the nightmare seemed to begin from that time. Because previously I have run the cases without problem, but after that, at first, the number of particle in lagrangian file in calculated time file exists much fewer than before(see below), then I recompiled the library and solver copied to my own computer, it comes out "mesh flux field does not exists, is the mesh actually moving?"(with mysprayFoam), then I tried sprayFoam(openfoam's original solver and libs), it comes out the message I posted. But later my friend tried with his computer(he doesn't use our remote processors), and the same case file can work. I guess there are two possible reasons: one is the memory space, the other is the "unclean" things from the finished case file I copied since before I can run the cases normally. Do you think it's reasonable?

wyldckat August 7, 2012 07:13

If possible, try rebooting your computer!?

As for your friend's computer, did he copy the files from your computer or from the other machine as well?

conceptone August 7, 2012 15:45

Actually, the situation is better now..I just switch to non-debug version.. It seems that Openfoam's code is not so robust as I imagine..
Thanks anyway!

All times are GMT -4. The time now is 06:47.