CFD Online Discussion Forums

CFD Online Discussion Forums (
-   OpenFOAM (
-   -   No convergence; floating point exception all the time (

Tobi September 18, 2012 18:16

No convergence; floating point exception all the time
2 Attachment(s)
Hi foamers,

I am trying to solve my case for one week now. Its always the same. The first 20 iterations look very good and all residuals going down like you dream it in your sleeping time. The continuity error is going to zero and everything looks very very good. But suddenly I get a peak in the pressure residual and after that in U,k,epsilon,h till I get the floating point error:

[0] #1  Foam::sigFpe::sigHandler(int) in "/home/shorty/OpenFOAM/OpenFOAM-2.1.x/platforms/linux64GccDPOpt/lib/"
[0] #2  in "/lib/x86_64-linux-gnu/"
[0] #3  Foam::hPsiThermo<Foam::pureMixture<Foam::sutherlandTransport<Foam::specieThermo<Foam::hConstThermo<Foam::perfectGas> > > > >::calculate() in "/home/shorty/OpenFOAM/OpenFOAM-2.1.x/platforms/linux64GccDPOpt/lib/"
[0] #4  Foam::hPsiThermo<Foam::pureMixture<Foam::sutherlandTransport<Foam::specieThermo<Foam::hConstThermo<Foam::perfectGas> > > > >::correct() in "/home/shorty/OpenFOAM/OpenFOAM-2.1.x/platforms/linux64GccDPOpt/lib/"
[0] #5 
[0]  in "/home/shorty/OpenFOAM/shorty-2.1.x/platforms/linux64GccDPOpt/bin/scalarRhoSimpleFoam"
[0] #6  __libc_start_main in "/lib/x86_64-linux-gnu/"
[0] #7 
[0]  in "/home/shorty/OpenFOAM/shorty-2.1.x/platforms/linux64GccDPOpt/bin/scalarRhoSimpleFoam"
[cfd:28469] *** Process received signal ***
[cfd:28469] Signal: Floating point exception (8)
[cfd:28469] Signal code:  (-6)
[cfd:28469] Failing at address: 0x3e800006f35
[cfd:28469] [ 0] /lib/x86_64-linux-gnu/ [0x7f310e9b64c0]
[cfd:28469] [ 1] /lib/x86_64-linux-gnu/ [0x7f310e9b6445]
[cfd:28469] [ 2] /lib/x86_64-linux-gnu/ [0x7f310e9b64c0]
[cfd:28469] [ 3] /home/shorty/OpenFOAM/OpenFOAM-2.1.x/platforms/linux64GccDPOpt/lib/ [0x7f3111ffbd4e]
[cfd:28469] [ 4] /home/shorty/OpenFOAM/OpenFOAM-2.1.x/platforms/linux64GccDPOpt/lib/ [0x7f31120025a2]
[cfd:28469] [ 5] scalarRhoSimpleFoam() [0x41849b]
[cfd:28469] [ 6] /lib/x86_64-linux-gnu/ [0x7f310e9a176d]
[cfd:28469] [ 7] scalarRhoSimpleFoam() [0x41c5cd]
[cfd:28469] *** End of error message ***
mpirun noticed that process rank 0 with PID 28469 on node cfd exited on signal 8 (Floating point exception).

I tried around with the mesh (created with sHM). CheckMesh is i.O. and no error occur.
I solve a diffuser geometry and the problem cells are the cells near the diffuser wall. I tried without layer and with layer. With layer the problem point is the end of the layer where it collapses (picture)...

I tried:

- without layer
- with layer
- refinement
- fvSchemes
- relaxFactors
- Solvers

is there anything I can do ?

Solver rhoSimpleFoam

With a lower velocity there is everything working :(
I have no more ideas.


Doug68 September 19, 2012 02:44

Read post 4 on this thread:

Maybe it helps.

Tobi September 19, 2012 04:01


Originally Posted by Doug68 (Post 382476)
Read post 4 on this thread:

Maybe it helps.

Hi thanks for that information.
You mean to scale it bigger, generate the mesh and scale it back.
Well I usually use that trick with very small geometry`s becouse therefor you get extreme small cells which do not pass the mesh criterion.

The trick bruno mentioned is good :) but is not working on my problem. But your post with the minRefinementCells is good to know. Thanks for that. I ll have a try on that :)

I read your thread till the end and wanna give you some info about your residuals in your thread :)


All times are GMT -4. The time now is 05:45.