CFD Online Discussion Forums

CFD Online Discussion Forums (
-   OpenFOAM (
-   -   problems running AMI (

MUZ November 14, 2012 09:06

problems running AMI
Hello Everyone,
I am simulating a rotating propeller at drift using the AMI in version 2.1.0. To get me started i applied no drift angle to the propeller (ie propeller was at zero degrees) and my case runs fine and gives me reasonable initial results. Now using the same set-up i applied a drift angle of -7.5 degrees to the propeller and the only parameters i changed this time around was the CofG and the radial velocity in my dynamicMeshDict.My case blows up when i run it and below is the error message :

Courant Number mean: 0.00585874 max: 1.7571
deltaT = 0.000111111
Time = 0.00444444

solidBodyMotionFunctions::rotatingMotion::transfor mation(): Time = 0.00444444 transformation: ((0.0596645 0.496599 0.226508) (0.882821 (0.466918 -0.0451955 -0.0239036)))
AMI: Creating addressing and weights between 5954 source faces and 6057 target faces
AMI: Patch source weights min/max/average = 0.00262479, 2.10845, 1.0221
AMI: Patch target weights min/max/average = 0, 2.44428, 1.01635
PIMPLE: iteration 1
#0 Foam::error::printStack(Foam::Ostream&) in "/opt/openfoam210/platforms/linux64GccDPOpt/lib/"
#1 Foam::sigFpe::sigHandler(int) in "/opt/openfoam210/platforms/linux64GccDPOpt/lib/"
#2 in "/lib/x86_64-linux-gnu/"
#3 Foam::divide(Foam::Field<double>&, double const&, Foam::UList<double> const&) in "/opt/openfoam210/platforms/linux64GccDPOpt/lib/"
#4 Foam::tmp<Foam::GeometricField<double, Foam::fvPatchField, Foam::volMesh> > Foam::operator/<Foam::fvPatchField, Foam::volMesh>(Foam::dimensioned<double> const&, Foam::tmp<Foam::GeometricField<double, Foam::fvPatchField, Foam::volMesh> > const&) in "/opt/openfoam210/platforms/linux64GccDPOpt/bin/pimpleDyMFoam

i have been through the forum and found that the problem causing this is the 0 in "AMI: Patch target weights min/max/average = 0, 2.44428, 1.01635" meaning there are some uncovered faces in my AMI region. My problem is that this case run perfectly well when there was no applied drift so using the same setup and changing parameters i have specified above i expect it to run. i have reduced maxCo, relaxation parameters etc to no avail. I have been stuck with this for a while and will require or appreciate any assistance. i have attached a link to the case that runs and the case that blows up. i noticed on the case that blows up is upon checking the various time steps it appears the rotor(ami1) is slipping gradually out of the stationary (ami2) as it is rotating which should not be the case. I initially thought i have got the axis of rotation wrong but i do not think so (correct me if i am wrong). Hope someone kindly help me.

the link to my case is


MUZ November 14, 2012 09:19

2 Attachment(s)
attached is the last time step of rotor and stator before it blows up. surface with edges is the rotor and surface is the stator.

MUZ November 15, 2012 06:25

Hello everyone,
have been working on this case still trying to figure out why i get the above error. was wondering if anyone could kindly offer any advice.

MUZ November 19, 2012 09:19

Hello Everyone,
Thanks for all who read my post. I am happy to say that my problem is solved.Thanks once again everyone

Lieven November 19, 2012 09:22

Could you also post your solution for future reference (in case someone else encounters the same problem)?

MUZ November 20, 2012 06:49


Originally Posted by Lieven (Post 392957)
Could you also post your solution for future reference (in case someone else encounters the same problem)?

Hello Lieven i modified my background mesh and strangely it did the tick i could post my back ground mesh if you want.

Lieven November 20, 2012 07:18

If it was 'simply' a mesh problem, that won't be necessary ;-)

All times are GMT -4. The time now is 18:22.