CFD Online Discussion Forums

CFD Online Discussion Forums (
-   OpenFOAM (
-   -   XiFoam : paraFoam not working (

researcher August 26, 2013 12:03

XiFoam : paraFoam not working
Hello openFoam friends !

Could anyone please figure what this problems is ? and here is how the problem goes:
i run XiFoam, just the one in tutorials, and it does it all except when i enter paraFoam and it says :

WARN file does not exist:
created temporary 'ras.OpenFOAM'

cannot find file

file: /home/sirat/OpenFOAM/sirat-2.2.1/run/tutorials/combustion/XiFoam/ras/system/controlDict at line 0.

From function regIOobject::readStream()
in file db/regIOobject/regIOobjectRead.C at line 73.

FOAM exiting

Could anybody please help me out ! :eek:

nimasam August 26, 2013 14:21

it seems you are not in test case directory :) in other word wrong directory :)
be careful where you type paraFoam it should be in testcase address

researcher August 26, 2013 20:12

XiFoam: paraFoam not working
Dear Nima
i ran it it from where i ran the ./Allrun command. Thats where the case itself is. Please any further suggestions?


researcher August 26, 2013 20:26

Dear Nima
ohhhhhh yes, i got it ! i had to go into the moriyo.... directory to run paraFoam !
and thanx much, frankly i sprang from the bed to the computer to do as you suggested ! hahaha



All times are GMT -4. The time now is 14:30.