CFD Online Discussion Forums

CFD Online Discussion Forums (
-   OpenFOAM (
-   -   Is twoPhaseEulerFoam applicable to 3D cases / delivering erroneous results? (

ThomasV November 11, 2013 09:10

Is twoPhaseEulerFoam applicable to 3D cases / delivering erroneous results?

I've got a question concerning the twoPhaseEulerFoam solver. From what I know this solver is meant to also work for 3D geometries. I ran into the following issue though:

I tried to do the same thing that is done for icoFoam in the tutorial i.e. using a cube and giving a fixed value for the velocity over one of the cube faces. Thus I did this for the velocity Ub (-> the continous phase). Initially I just did it for the velocity in x-direction and everything works fine giving a result that looks like this (velocity at the "top" is fixed) after a short time:

At first I didn't do any more testing but when writing my own solver based upon twoPhaseEulerFoam I at one point tried out a velocity in the z-direction meant to interact with a concentration transport I had integrated. I got very strange results i.e. the velocities in z-direction immediately vanished. I then deactivated one extension of mine after another until I got back to basically the twoPhaseEulerFoam solver which I afterwards used on the very same testcase to check out if I did something wrong or if this also is the case for the original solver. Well it turned out that the problem also is present for the twoPhaseEulerFoam solver. When using the very same cube in the very same case but defining a fixed velocity into the z-direction instead of the x-direction one gets this:

Notice not only the difference in the values but it also is the same view in which the z-direction actually isn't really visible. In views with the z-axis lying within the screen plane nothing is visible though:

So my question is: Did I do something wrong or is there a misunderstanding in a way that twoPhaseEulerFoam is meant just for 2-dimenionsal cases? In order for everyone to check this out I did upload the testcases (don't mind some for twoPhaseEulerFoam superfluous entries / files):

All times are GMT -4. The time now is 17:23.