CFD Online Logo CFD Online URL
www.cfd-online.com
[Sponsors]
Home > Forums > OpenFOAM

interFoam not running

Register Blogs Members List Search Today's Posts Mark Forums Read

Reply
 
LinkBack Thread Tools Display Modes
Old   March 9, 2017, 14:50
Default interFoam not running
  #1
New Member
 
Ashok
Join Date: Feb 2017
Posts: 7
Rep Power: 2
ashokmoravaneni is on a distinguished road
Hello everyone,
I found no error messages related to meshing,setFields etc but as I finally run interFoam it shows something like this

Selecting incompressible transport model HerschelBulkley
Selecting incompressible transport model Newtonian
#0 Foam::error:rintStack(Foam::Ostream&) at ??:?
#1 Foam::sigFpe::sigHandler(int) at ??:?
#2 ? in "/lib/x86_64-linux-gnu/libc.so.6"
#3 ? in "/lib/x86_64-linux-gnu/libm.so.6"
#4 pow in "/lib/x86_64-linux-gnu/libm.so.6"
#5 Foam:ow(Foam::dimensioned<double> const&, Foam::dimensioned<double> const&) at ??:?
#6 Foam::interfaceProperties::interfaceProperties(Foa m::GeometricField<double, Foam::fvPatchField, Foam::volMesh> const&, Foam::GeometricField<Foam::Vector<double>, Foam::fvPatchField, Foam::volMesh> const&, Foam::IOdictionary const&) at ??:?
#7 Foam::immiscibleIncompressibleTwoPhaseMixture::imm iscibleIncompressibleTwoPhaseMixture(Foam::Geometr icField<Foam::Vector<double>, Foam::fvPatchField, Foam::volMesh> const&, Foam::GeometricField<double, Foam::fvsPatchField, Foam::surfaceMesh> const&) at ??:?
#8 ? in "/opt/openfoam4/platforms/linux64GccDPInt32Opt/bin/interFoam"
#9 __libc_start_main in "/lib/x86_64-linux-gnu/libc.so.6"
#10 ? in "/opt/openfoam4/platforms/linux64GccDPInt32Opt/bin/interFoam"
Floating point exception (core dumped)

Any sort of Help is appreciated. Thanks
ashokmoravaneni is offline   Reply With Quote

Old   March 17, 2017, 09:53
Default
  #2
Senior Member
 
Saideep
Join Date: Apr 2015
Location: INDIA
Posts: 165
Rep Power: 3
Saideep is on a distinguished road
Nothing can be told from your post.
Floating point error says the problem, it is because your dividing a fraction by 0 somewhere in your code. Probably for others to help you should explain what your solving, a figure is better and what changes you made in your code.

Saideep
Saideep is offline   Reply With Quote

Old   March 19, 2017, 06:41
Default
  #3
New Member
 
Ashok
Join Date: Feb 2017
Posts: 7
Rep Power: 2
ashokmoravaneni is on a distinguished road
I managed to get rid of this problem. I have changed the direction of z coordinates and then interFoam runs successfully.
ashokmoravaneni is offline   Reply With Quote

Reply

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On


Similar Threads
Thread Thread Starter Forum Replies Last Post
interFoam running blowing up sandy13 OpenFOAM Running, Solving & CFD 2 May 5, 2015 07:16
how to run the propeller Tutrial immortality OpenFOAM Running, Solving & CFD 10 February 22, 2014 10:33
interFoam process forking on HPC using PBS JFM OpenFOAM Running, Solving & CFD 2 February 4, 2014 09:49
Something weird encountered when running OpenFOAM in parallel on multiple nodes xpqiu OpenFOAM Running, Solving & CFD 2 May 2, 2013 04:59
InterFoam / InterDyFoam running problem anon_c OpenFOAM Running, Solving & CFD 1 August 26, 2009 03:54


All times are GMT -4. The time now is 23:32.