CFD Online Logo CFD Online URL
www.cfd-online.com
[Sponsors]
Home > Forums > Software User Forums > OpenFOAM

PlaneWall2D Tutorial is broken and does not show proper T profile

Register Blogs Members List Search Today's Posts Mark Forums Read

Reply
 
LinkBack Thread Tools Search this Thread Display Modes
Old   March 19, 2017, 06:35
Question PlaneWall2D Tutorial is broken and does not show proper T profile
  #1
Member
 
Emre
Join Date: Nov 2015
Location: Izmir, Turkey
Posts: 97
Rep Power: 8
ordinary is on a distinguished road
Hi,

I try to run planeWall2D tutorial which is posted here: http://openfoamwiki.net/index.php/Ge..._-_planeWall2D

But it does not show proper temperature profile as stated in the tutorial post:






But mine is this:
heat.jpg

What is wrong with this tutorial? I use foam-extend-3.2 which does not contain this openFOAM tutorial but still ...
ordinary is offline   Reply With Quote

Old   May 23, 2018, 10:59
Default
  #2
Member
 
Emre
Join Date: Nov 2015
Location: Izmir, Turkey
Posts: 97
Rep Power: 8
ordinary is on a distinguished road
It still seems broken. No temperature contour. paraFoam doesn't work.
ordinary is offline   Reply With Quote

Old   May 24, 2018, 05:59
Default
  #3
Senior Member
 
Robert
Join Date: May 2015
Location: Bremen, GER
Posts: 294
Rep Power: 10
RobertHB is on a distinguished road
Did your solver run at all? It doesn't look like it. So its not a paraview problem.
RobertHB is offline   Reply With Quote

Old   May 24, 2018, 18:16
Default
  #4
Senior Member
 
Wouter van der Meer
Join Date: May 2009
Location: Elahuizen, Netherlands
Posts: 203
Rep Power: 16
wouter is on a distinguished road
Hello ordinary,
In your paraview you are looking at time 0, if the problem has run, you need to forward the time to last (using the attached key on paraview).


hope this helps
Wouter
Attached Images
File Type: png Selection_008.png (787 Bytes, 24 views)
wouter is offline   Reply With Quote

Old   May 25, 2018, 03:17
Default
  #5
Senior Member
 
Robert
Join Date: May 2015
Location: Bremen, GER
Posts: 294
Rep Power: 10
RobertHB is on a distinguished road
Quote:
Originally Posted by wouter View Post
Hello ordinary,
In your paraview you are looking at time 0, if the problem has run, you need to forward the time to last (using the attached key on paraview).
Thats correct but will not help in this case as there are no further timesteps (see the zero behind the time counter).
RobertHB is offline   Reply With Quote

Old   May 25, 2018, 07:05
Default
  #6
New Member
 
Join Date: Aug 2012
Posts: 15
Rep Power: 11
sweet_satan is on a distinguished road
Hello ordinary,


You are right, this tutorial does not work on some versions of OpenFOAM. For example to make it work on OpenFoam 4.1 you have to make changes in BCs as described in this post:
planeWall2D tutorial: error running chtMultiRegionSimpleFoam


You can try similar trick on your foam-extended but I dont guarantee it will work.


Also for post processing make sure you follow these steps:


Quote:
2.3 Post-Processing

When the script Allrun finishes executing, you'll have the following 3 files:
Code:
planeWall2D{bottomAir}.OpenFOAM planeWall2D{topAir}.OpenFOAM planeWall2D{wall}.OpenFOAM
Start up ParaView from the command line and open those 3 files:
Code:
paraview
sweet_satan is offline   Reply With Quote

Old   May 26, 2018, 09:11
Default
  #7
Member
 
Emre
Join Date: Nov 2015
Location: Izmir, Turkey
Posts: 97
Rep Power: 8
ordinary is on a distinguished road
Thank you for your attention RobertHB.
Quote:
Originally Posted by RobertHB View Post
Did your solver run at all? It doesn't look like it. So its not a paraview problem.
Yes, I did via ./Allrun:
Code:
ordinary@toshiba:~/FOAM_RUN/planeWall2D$ openfoam50
ordinary@toshiba:~/FOAM_RUN/planeWall2D$ ./Allrun
Running blockMesh on /home/ordinary/FOAM_RUN/planeWall2D
Running topoSet on /home/ordinary/FOAM_RUN/planeWall2D
Running splitMeshRegions on /home/ordinary/FOAM_RUN/planeWall2D
Running chtMultiRegionSimpleFoam on /home/ordinary/FOAM_RUN/planeWall2D

creating files for paraview post-processing

Created 'planeWall2D.blockMesh'
Created 'planeWall2D.OpenFOAM'
Created 'planeWall2D{bottomAir}.OpenFOAM'
Created 'planeWall2D{topAir}.OpenFOAM'
Created 'planeWall2D{wall}.OpenFOAM'
ordinary@toshiba:~/FOAM_RUN/planeWall2D$ paraFoam
Thank you wouter.
Quote:
Originally Posted by wouter View Post
Hello ordinary,
In your paraview you are looking at time 0, if the problem has run, you need to forward the time to last (using the attached key on paraview).


hope this helps
Wouter
I type paraFoam. And in ParaView, I enable 'T' volume fields in order to see it. Then I click that button (or play button).
temp.png
temp2.png


Thank you sweet_satan. I run this case in OpenFOAM 5.0.
ordinary is offline   Reply With Quote

Reply

Tags
chtmultiregionsimplefoam, foam extend 3.2, heat tranfer

Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are On
Refbacks are On



All times are GMT -4. The time now is 14:04.