CFD Online Logo CFD Online URL
www.cfd-online.com
[Sponsors]
Home > Forums > Software User Forums > OpenFOAM

command not found when i use checkMesh command

Register Blogs Members List Search Today's Posts Mark Forums Read

Like Tree2Likes
  • 1 Post By Tobi
  • 1 Post By zlw306

Reply
 
LinkBack Thread Tools Search this Thread Display Modes
Old   June 21, 2017, 07:52
Default command not found when i use checkMesh command
  #1
New Member
 
Liwei Zhang
Join Date: Jun 2017
Posts: 10
Rep Power: 5
zlw306 is on a distinguished road
Hello everyone!I used fluent3DMeshToFoam to convert a propeller mesh in openfoam.After that when i used checkMesh command under my case dir.it shows that :command not found.The same situation happened when i used mergeMeshes command.I can't figure out the problem.Thanks !


Sent from my iPhone using CFD Online Forum mobile app
zlw306 is offline   Reply With Quote

Old   June 22, 2017, 13:40
Default
  #2
Super Moderator
 
Tobi's Avatar
 
Tobias Holzmann
Join Date: Oct 2010
Location: Augsburg
Posts: 2,451
Blog Entries: 6
Rep Power: 46
Tobi has a spectacular aura aboutTobi has a spectacular aura aboutTobi has a spectacular aura about
Send a message via ICQ to Tobi Send a message via Skype™ to Tobi
Hi,

this is an indication that:
  • your FOAM environment is not loaded correctly
  • the applications were not compiled correctly
Did you install FOAM or compiled it yourself? In $FOAM_APPBIN you should have the checkMesh application and other one. If there is nothing, there is probably something wrong with your FOAM installation / compilation and you should investigate into that first. Bruno and others did a great job for collecting everything to the openfoamwiki. Have a look and you will find what you have to do
zlw306 likes this.
__________________
Keep foaming,
Tobias Holzmann
Tobi is offline   Reply With Quote

Old   June 26, 2017, 05:49
Default
  #3
New Member
 
Liwei Zhang
Join Date: Jun 2017
Posts: 10
Rep Power: 5
zlw306 is on a distinguished road
Quote:
Originally Posted by Tobi View Post
Hi,

this is an indication that:
  • your FOAM environment is not loaded correctly
  • the applications were not compiled correctly
Did you install FOAM or compiled it yourself? In $FOAM_APPBIN you should have the checkMesh application and other one. If there is nothing, there is probably something wrong with your FOAM installation / compilation and you should investigate into that first. Bruno and others did a great job for collecting everything to the openfoamwiki. Have a look and you will find what you have to do
I really apprexiate for your kindness,Tobi.I acually did sometihing wrong with my compilation.And i have learned much from your video and tutorials.Thanks for your kindness again!


Sent from my iPhone using CFD Online Forum mobile app
Tobi likes this.
zlw306 is offline   Reply With Quote

Reply

Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are On
Refbacks are On


Similar Threads
Thread Thread Starter Forum Replies Last Post
[mesh manipulation] checkMesh: command not found ggulgulia OpenFOAM Meshing & Mesh Conversion 3 March 1, 2018 09:37
[Helyx OS] Helyx-OS - blockMesh command not found pft OpenFOAM Community Contributions 4 July 6, 2016 13:38
[OpenFOAM] run paraFoam command results in error: line 267: paraview: command not found. Asik ParaView 1 December 25, 2013 12:45
OF 1.6 | Ubuntu 9.10 (64bit) | GLIBCXX_3.4.11 not found piprus OpenFOAM Installation 22 February 25, 2010 14:43
Problems in compiling paraview in Suse 10.3 platform chiven OpenFOAM Installation 3 December 1, 2009 08:21


All times are GMT -4. The time now is 13:54.