CFD Online Logo CFD Online URL
www.cfd-online.com
[Sponsors]
Home > Forums > Software User Forums > OpenFOAM

Cannot find file "points" in directory "air/polyMesh" in times "0" down to constant

Register Blogs Members List Search Today's Posts Mark Forums Read

Like Tree2Likes
  • 1 Post By adhiraj
  • 1 Post By Yann

Reply
 
LinkBack Thread Tools Search this Thread Display Modes
Old   April 5, 2020, 00:26
Exclamation Cannot find file "points" in directory "air/polyMesh" in times "0" down to constant
  #1
New Member
 
Raja
Join Date: May 2017
Posts: 2
Rep Power: 0
rajaseenivasan is on a distinguished road
Hi


I am trying to perform the external solar load tutorial in the Openfoam. I am getting the following error while running the "chtMultiRegionFoam" command.

raja@raja:~/OpenFOAM/raja-6/run/externalSolarLoad$ chtMultiRegionFoam
/*---------------------------------------------------------------------------*\
========= |
\\ / F ield | OpenFOAM: The Open Source CFD Toolbox
\\ / O peration | Website: https://openfoam.org
\\ / A nd | Version: 6
\\/ M anipulation |
\*---------------------------------------------------------------------------*/
Build : 6-fa1285188035
Exec : chtMultiRegionFoam
Date : Apr 04 2020
Time : 20:22:58
Host : "raja"
PID : 12699
I/O : uncollated
Case : /home/raja/OpenFOAM/raja-6/run/externalSolarLoad
nProcs : 1
sigFpe : Enabling floating point exception trapping (FOAM_SIGFPE).
fileModificationChecking : Monitoring run-time modified files using timeStampMaster (fileModificationSkew 10)
allowSystemOperations : Allowing user-supplied system call operations

// * * * * * * * * * * * * * * * * * * * * * * * * * * * * * * * * * * * * * //
Create time

Create fluid mesh for region air for time = 0



--> FOAM FATAL ERROR:
Cannot find file "points" in directory "air/polyMesh" in times "0" down to constant

From function virtual Foam::IOobject Foam::fileOperation::findInstance(const Foam::IOobject&, Foam::scalar, const Foam::word&) const
in file global/fileOperations/fileOperation/fileOperation.C at line 871.

FOAM exiting






I am just running the tutorial file. I didn't do any changes. Kindly help me to solve the issue.
rajaseenivasan is offline   Reply With Quote

Old   April 5, 2020, 17:26
Default
  #2
Senior Member
 
Adhiraj
Join Date: Sep 2010
Location: Maryland, United States
Posts: 174
Rep Power: 12
adhiraj is on a distinguished road
Perhaps you need to run blockMesh first?
rajaseenivasan likes this.
adhiraj is offline   Reply With Quote

Old   April 6, 2020, 05:56
Default
  #3
Senior Member
 
Yann
Join Date: Apr 2012
Location: France
Posts: 186
Rep Power: 12
Yann is on a distinguished road
When it comes to multi region solvers, there are several important steps to do in order to generate the meshes and setup the case before running the solver. (blockMesh will not be enough)

Check the Allrun scripts in the tutorial to understand what's done so you can reproduce it.
(Or simply run the Allrun or Allrun-parallel script if you just want to get it done)


Cheers,
Yann
rajaseenivasan likes this.
Yann is online now   Reply With Quote

Old   April 6, 2020, 13:30
Thumbs up
  #4
New Member
 
Raja
Join Date: May 2017
Posts: 2
Rep Power: 0
rajaseenivasan is on a distinguished road
Ok. Thanks. It worked



Quote:
Originally Posted by Yann View Post
When it comes to multi region solvers, there are several important steps to do in order to generate the meshes and setup the case before running the solver. (blockMesh will not be enough)

Check the Allrun scripts in the tutorial to understand what's done so you can reproduce it.
(Or simply run the Allrun or Allrun-parallel script if you just want to get it done)


Cheers,
Yann
rajaseenivasan is offline   Reply With Quote

Reply

Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are On
Refbacks are On


Similar Threads
Thread Thread Starter Forum Replies Last Post
[Other] Tabulated thermophysicalProperties library chriss85 OpenFOAM Community Contributions 61 November 9, 2020 11:52
polynomial BC srv537 OpenFOAM Pre-Processing 4 December 3, 2016 10:07
SparceImage v1.7.x Issue on MAC OS X rcarmi OpenFOAM Installation 4 August 14, 2014 07:42
centOS 5.6 : paraFoam not working yossi OpenFOAM Installation 2 October 9, 2013 02:41
[swak4Foam] Error bulding swak4Foam sfigato OpenFOAM Community Contributions 18 August 22, 2013 13:41


All times are GMT -4. The time now is 09:29.