CFD Online Discussion Forums

CFD Online Discussion Forums (
-   OpenFOAM (
-   -   Problem with reconstructPar (

fabianpk July 25, 2006 03:12

Hello, I'm having this prob

I'm having this problem with reconstructPar that I really can't figure out. I made a fresh OpenFOAM installation and did an Allwmake. As far as I can see there were no severe errors when doing the Allwmake, However, when I run reconstructPar on my case (which is binary uncompressed), I get:

*** glibc detected *** double free or corruption (out): 0xb4cbb008 ***

Since I never had problems with OpenFOAM 1.2, I went over the release notes, but couldn't find anything adressing this. This is on a 32-bit machine running Suse, kernel 2.6.13-15.11. I get a slightly different error message on a 64 bit machine (where the case is run), but it stops in the same place. On 64 bit I get:

/lib64/tls/ [0x392ce2e380]
reconstructPar [0x464da1]
reconstructPar [0x4669f2]
reconstructPar [0x41be23]

Any indication of where the error could be, would help.

chris1980 July 25, 2006 03:51

According to 'double free' hin
According to 'double free' hint there is some problem with the memory allocation.

Are you sure that there is not error when you rebuild OF?

What is about OF 1.3?

mattijs July 25, 2006 04:02

Recompile reconstructPar with
Recompile reconstructPar with -DFULLDEBUG -g -O0 in the Make/options and use gdb.

fabianpk July 25, 2006 06:42

I was just about to do this, b
I was just about to do this, but then I remembered the restructuring of the mesh parallelization made in 1.3. So I ran blockMesh (v 1.3), and now it works. Sorry for wasting your time. The case was old and I had only run version 1.2 of blockMesh.

maddalena August 14, 2007 05:53

Hello everybody, I have some
Hello everybody,
I have some problems with reconstructing my domain after a parallel computation. I am running a case with 16 processors on 4 nodes of the cluster. The simulation is finished, since the log file says so. When recomposePar started to do its job, everything was fine, until the recompositon of folder 14, when the recomposition stopped. The problem is that I started recomposePar with a script file, so I do not have any error message on the screen, neither I have any error files that are usually created when there is something wrong. If I check on the list of running processes, my job is still there, but all the four nodes I am using are not load.
Is there someone who has an idea of what is wrong and how to solve it without killing the job? If I do so, I will lose my place on the cluster and there is a long queue of jobs that are waiting... Moreover, I really need those results as soon as possible...
I've already run similar simulations controlling them with the same script file, so the problem is not on it...
Thanks for your help,


maddalena August 14, 2007 09:17

Problem solved. There was one
Problem solved. There was one of the node of the cluster that was not working properly. So I copied the files from the cluster to my own pc and I used recomposePar from it. Obviously, it worked. ;-)


All times are GMT -4. The time now is 06:39.