CFD Online Discussion Forums

CFD Online Discussion Forums (
-   OpenFOAM (
-   -   Which linux distribution (

hsieh June 25, 2007 09:45

Hi, I have been running Ope

I have been running OpenFOAM on SuSE 64-bit OS without any problem.

I recently got a new computer (ASUS M2N-E Sli, AMD X2 6000+, SATA 3 Gb/S HD, NVidia Quadro video, USB Keyboard/Mouse). It refused to install SuSE 10.1. SuSE 10.2 64 bit installed without any problem. Then, I installed OpenFOAM 1.4. The computer crashed. After that, after booting up and logged onto the user account, the system froze. Ths same system was dual-boot with Win XP. XP has no problem.

So, I would like to try out different linux distribution, such as Fedora, Ubuntu....

Has anyone tried OF-1.4 on Ubuntu or other latest linux?



alberto June 25, 2007 09:55

Hello, there're some thread a
there're some thread about using OF with non-SuSE distributions. Please, search the discussion board. In general, OF works on them, with some minor issue for FoamX (lacking libraries).

However I don't think the installation of OF 1.4 is the cause of the crash of your system.

OpenSUSE 10.2 uses a different gcc version from OF 1.4, but this should not be a problem. You just have to re-compile OF.

Did you check if your hardware is supported by the distribution?

With kind regards,

ville June 25, 2007 09:59

Hi, I just installed OF-1.4 o
I just installed OF-1.4 on Kubuntu (Feisty Fawn distribution). You need to add the tck, tk,
binutils (and the .dev) packages to make it work.

lr103476 June 25, 2007 10:10

Hi, Since a couple of month

Since a couple of months, I use Kubuntu Feisty Fawn with success. Indeed, you have to install some dev packages, but then everything works fine.

I compile everything (OF-1.3 and OF-1.4 stuff) using the system compiler, 4.2.1, which comes with Feisty.

Regards, Frank

connclark June 25, 2007 12:02

I have compiled OpenFOAM on Ge
I have compiled OpenFOAM on Gentoo AMD64 and I have it working to some extent. It takes a few code hacks to get it to build (Note: I haven't got some of the parallel utilities to build yet). Its been a pain to get paraview-2.4.4 running right but thats because the don't have a source tarball that has the patches to read the native foam format for download.

hsieh June 25, 2007 12:25

Hi, Thanks for the reply.

Thanks for the reply.

I remember similar discussion quite a while back, must be the OpenFOAM-1.1 (or OF-1.0.1) days. It was SuSE 9.3 then, so, I was hoping to get some update in this area.

Most likely, this is not due to OF installation and is due to hardware compatiblity with linux. I do have 6 Dell workstations running SuSE 10.2 with OpenFOAM without any problem.

I have done some search on this, but, could not get any good solution yet. So, I was hoping a linux distribution newer than SuSE 10.2 will help in this area.


philippose June 25, 2007 13:33

Hello, Good day! To add

Good day!

To add on to the list of Linux flavours on which OpenFOAM works....

I have used OpenFOAM on Fedora Core 5, 6 and now currently its running on Fedora 7.

If I remember right, OpenFOAM worked straight out of the box on a stock, unmodified Fedora distribution (but using the GCC binary version as recommended in the OpenFOAM installation).

The only caveat I vaguely recall, is, that you may have to install lestiff, or OpenMotif, to fulfill some library requirement for FoamX.... and probably add some symbolic links for specific libraries, again for FoamX.

Have a nice day!


alberto June 25, 2007 14:27

Hello again Pei, I'd suggest y
Hello again Pei, I'd suggest you to run memtest on that workstation too, just to be sure.

Random crashes are not a good sign :-(


sradl June 26, 2007 02:01

Hello, I had a similar prob

I had a similar problem and just did a HD-install of the Knopppix 5.1.1 DVD that I've downloaded from

It works perfectly and includes all relevant pre- and post-processing tools (e.g. paraview). So I just can recommend you this DVD, you will be able to run OF-1.4 within 1-2 hours without major troubles

Stefan Radl

hsieh June 26, 2007 15:43

Thanks a lot Stefan! I ha
Thanks a lot Stefan!

I have used knoppix for a couple of years and loved it. I will download this OpenFOAM version tonight.

Also, thanks Alberto! I ran memtest came with SuSE and got several errors. One of the memory sticks may be bad (I am waiting for OCZ to reply). I am trying two new pairs to see if this problem persists.


alberto June 26, 2007 16:26

Good news it wasn't SUSE fault
Good news it wasn't SUSE fault.

I had various experiences of PC's where all _seemed_ OK under Windows while Linux immediately crashed due to RAM issues. This is mainly due to the different allocation strategies adopted by these two OSes.


benru June 27, 2007 06:46

Hi all, I use OF-1.4 (total
Hi all,

I use OF-1.4 (total packs OF-1.4 - with gcc-4.1.2 & Java) on Debian (Last Stable - 4.0, april 2007) Linux (32-bit). All is ok, some troubles with recompilation after cumulative patch installation were solved with help from Forum

Concerning Ubuntu, it is desireble to have direct internet connection to add some packets from repositories, which are absent in CD-version of their distributive pack (DVD-version is ok - tested with OF-1.3).

All new Linux distributions is suitable for OF, but time2time it is need to check, update or install different packets (concerning bison, flex++, binutils - for main part, cmake - for graphics).


All times are GMT -4. The time now is 07:33.