CFD Online Discussion Forums

CFD Online Discussion Forums (
-   OpenFOAM (
-   -   New Dell D620 Laptop dualboot problems (

lr103476 May 4, 2007 08:10

Hi everybody, I do not know
Hi everybody,

I do not know if this is the place to post my problem, but I know that some of you are using laptops running linux and most of you like computer (problems :-)).

So, this is the problem. Yesterday, my new Dell laptop arrived and the pre-installed windows worked fine. I noticed the weird 100Meg Dell Utility partition, which I ignored. Immediately I started installing Kubuntu 7.04 which is working really well on this laptop. The bootloader GRUB was installed into the Master Boot Record, which should be OK.

The problem is that windows rewrites the MBR every time it boots which makes the computer unbootable.
So, after every windows boot I have to recover grub using the ubuntu livecd. It seems that the weird Dell Utility partition has something to do with this.

Has anyone experience with Dell laptops and the weird Dell partitions?

Regards, Frank

dmoroian May 4, 2007 08:22

Well, I have a dell laptop but
Well, I have a dell laptop but I don't have your problem. Though, the minute I got it, I erased everything and reinstalled windows and linux (slackware).
In your case I suspect that windows vista is "repairing" the "corrupted" MBR. I don't think this has anything to do with the dell utility partition.


lr103476 May 4, 2007 08:31

Indeed, I also think that wind
Indeed, I also think that windows XP (not Vista) 'repairs' the MBR. As if I windows knows what's good for me, there is a reason why I changed the MBR :-(.

Furthermore, if I understand it right, you had the problem for a minute and then you reformatted the whole disc. So, you also wiped the extra Dell partition and you installed a ordinary winXP version. Right?


lillberg May 4, 2007 08:38

Hi Frank, Noticed on the in
Hi Frank,

Noticed on the internet that Vista causes some trouble. Search Google and ubuntu forums.

If you recieved proper CD's with your Dell (not for sure nowdays) whipe the disc (including the Dell utility) and reinstall.

Try openSuSE 10.2 with KDE which has good support for dual OP's.

I'm running my windows XP partition under vmware in SuSE 10.2. Works like a charm after some fiddling to get the ntloader and SATA/SCSI support working.

Regards, Eric

lr103476 May 4, 2007 08:52

Hi, The Dell laptop came wi

The Dell laptop came with a re-installation CD of Windows XP without drivers and stuff, which are already on disc or in the 'hidden' Dell Utility partition.

Of course, a complete format of the HD should always work. When the Dell re-install CD is coupled somehow to the information on the partition, I could always install from any other official winXP cd.

I have used (open)Suse for a couple of years, but after the deal between MicroSoft and Novell, I began to search for alternatives. I've tried Ubuntu 6, Debian, Fedora, but I found OpenSuse10.2 still the best choice, untill I gave Kubuntu 7.04 a try. All the hardware is supported out of the box (including duoCore cpus) and I really like the apt-get thing instead of yast from suse.

Regards, Frank

grtabor May 4, 2007 11:25

I've recently sorted out dual-
I've recently sorted out dual-booting a Dell laptop for a student. Used SuSE partition tools to resize the windows partition, installed SuSE, that worked fine. Problem was, Windows Vista refused to boot (even from CD). Eventually I found that it was checking the disk size against what it thought was correct and not liking what it found. I had to drop back to an earlier Windows version (2000, I believe) to get a disk checking utility which was able to straighten things out enough for Vista to run.


lr103476 May 5, 2007 13:49

I solved the problem. Afte
I solved the problem.

After a re-installation of grub, using the kubuntu installation disc, I started an investigation to find the origin of the problem. I noticed that not login to windows did not screw the Master Boot Record, which led to the conclusion that one of the startup service/programs somehow 'recovers' the MBR. At first I switched everything off (diagnostic mode) and I just could login and reboot as usual. Then I added the programs which I normally need, until the redundant services/program remained unchecked. Now everything works, but I do not know yet which program causes the MBR 'recovery'.

As for OpenFOAM, I just recompiled the whole package with gcc 4.1.2 which came with Kubuntu 7.04. I only needed to install g++ and binutils-dev to obtain the liberty stuff.....

Regards, Frank

lr103476 May 6, 2007 04:44

Allright, again some problems.
Allright, again some problems.....

I recompiled the 32bit development version from 28-03-2007 using the ubuntu's version of gcc 4.1.2, which should be OK. Recompilation succeeded without any errors, but I am not able to run any applications which are depending on Just icoDyMFoam gives me the following error:

icoDyMFoam: symbol lookup error: /home/frankl/OpenFOAM/OpenFOAM-1.3/lib/linuxGcc4DPOpt/ undefined symbol: _ZTIN4Foam13dynamicFvMeshE

This also happens for moveDynamicMesh, but not for moveMesh.

Has anyone seen this before, me not....

What kind of compilation setup is recommended on such a Centrino CoreDuo T7200 2GHz processor. (I dont want to go back to suse, since all my other stuff works very well!).

Regards, Frank

alberto May 6, 2007 08:33

No particular compilation is r
No particular compilation is required for your system.

If you switch to OpenFOAM 1.4, you won't need to recompile the solver, because the binaries are already compiled with gcc 4.1.2.


lr103476 May 7, 2007 11:35

Ok, OpenFOAM 1.4 is working fi
Ok, OpenFOAM 1.4 is working fine, but I had to try the modified movingCone tutorial from H. Weller as posted in another topic. I dont use gcc 4.1.2 which came with OpenFoam, but the one which came with ubuntu.

Nevertheless, OpenFOAM 1.3 is still not working:

icoDyMFoam: symbol lookup error: /home/frankl/OpenFOAM/OpenFOAM-1.3/lib/linuxGcc4DPOpt/ undefined symbol: _ZTIN4Foam13dynamicFvMeshE

I have never seen this before.......

Regards, Frank

msrinath80 May 10, 2007 15:27

Frank: I realize that this is
Frank: I realize that this is off-topic, but I am only curious. What do you mean when you say the following:

"I have used (open)Suse for a couple of years, but after the deal between MicroSoft and Novell, I began to search for alternatives"

If you oppose the M$-Novell deal that much why do you even bother using Windows with dual-boot? Try to make up your mind. Please don't get me wrong.

lr103476 May 10, 2007 16:08

Haha, you're absolutely right!
Haha, you're absolutely right! Nowadays, I barely use windows, but sometimes I need to use some programs which are running on windows (tecplot when we run out of licenses or powerpoint 2003 presentations or playing some games). Some people ask me for certain MS file formats....I also don't like VMware, since that is very slow on my machines.

The laptop that I now have is owned by the University, so it came with windows, with all its bad booting habits:-( Right now, everything is working fine, but indeed I have a 30Gb windows partition which is barely used:-(

I really like the linux community and all the free and easy installable software. With previous linux distro's I had some problems with dvd burning / usb disks, video playback or 3d graphics or making presentations. But with the last couple of linux kernels (opensuse 10.2 or kubuntu 7.04 ) I have no problems at all. Also OpenOffice 2.2 is getting better and better.....The only thing that bothers me sometimes is the sound quality and photo printing (printing in general).

So it is only a matter of time that I reclaim the space on my disk which is occupied by microsoft.

msrinath80 June 2, 2007 02:39

Frank, how does the T7200 scal
Frank, how does the T7200 scaleup? Do you get 2x speedup when you use both cores. I have a similar laptop. I'm wondering if the 4MB L2 cache will make some difference? Any interesting experiences from your side?

msrinath80 June 2, 2007 02:41

Oh, by the way, my notebook is
Oh, by the way, my notebook is a Fujitsu S7110 which features a 64 bit motherboard. So I run Feisty Fawn 64-bit Ubuntu.

lr103476 June 2, 2007 06:08

Hi pUI, I don't have much time
Hi pUI, I don't have much time right now, but I did take a quick look on this. Using OF1.3 I did not manage to get the parallel stuff working (some problems with mpi, i dont really understand), but OF.14 works both serial and parallel. I ran a testcase of a plunging cylinder on a mesh with 35000 cells. I only simulated for about 100 timesteps. OF1.4 serial took about 175 seconds, whereas the OF1.4 parallel calculation needed 105 seconds. So this is an speed increase of about 70%. I think that there is a lot to gain when using larger meshes.

Considering the 4MB l2 cache, I don't know how to test it influence, since you can't turn it on/off or change the size. All that I know is that while runnning a parallel (or 2 serials) job the laptop is still very usable, which might be the result of the large cache.

Regards, Frank

All times are GMT -4. The time now is 22:50.