CFD Online Discussion Forums

CFD Online Discussion Forums (
-   OpenFOAM (
-   -   cmake: No such file or directory (

marupio April 27, 2009 20:58

cmake: No such file or directory
Everything works when I install OpenFOAM 1.5 on ubuntu 8.10 (64 bit) except for paraFoam. When I try to view the cavity flow results, it opens, but there's nothing useful being displayed, and it crashes when I try to do streamlines. So I assume it is my paraView conflicting with Qt (4.4.3 on my installation).

Here's the thing that really gets me. When I try to compile paraview, it doesn't understand the cmake command in the script. Typing 'cmake' in the terminal gives:

bash: /home/dave/OpenFOAM/ThirdParty/cmake-2.4.6/platforms/linux64/bin/cmake: No such file or directory

But it's there. The cmake application and directories are there, exactly where it says it isn't. Does anyone have any idea what's going on here?

marupio April 28, 2009 18:11

I got cmake to behave. All I did was update my video driver with ATI supplied drivers. That seems totally unrelated, but that's the only thing I did between [not-working] and [working] reboots.

chiven May 1, 2009 02:29

how about the results of running foamInstallationTest?

please run the command in the terminal:

which cmake

I have ever install cmake by myself. you also can do it, it is very simple.

marupio May 1, 2009 10:21

Before and after:
I have 2 installations of Ubuntu - one where I (somehow) solved the problem, and the other where I haven't yet solved it.

Problem solved machine:
which cmake

Problem not solved machine:
which cmake

bash: /home/dave/OpenFOAM/ThirdParty/cmake-2.4.6/platforms/linux64/bin/cmake: No such file or directory

marupio May 1, 2009 16:15

I just installed Ubuntu on my laptop. Ran into the cmake problem again. Switching to the ATI supplied drivers solved it. Bizare.

mcarpe June 15, 2009 13:11

Hello, I've got the same problem on a 64 bit Ubuntu machine. Unfortunately I cannot try the solution above because I've got an nvidia card :)

Any other solution? It seems a really odd problem.....

All times are GMT -4. The time now is 09:16.