CFD Online Discussion Forums

CFD Online Discussion Forums (
-   OpenFOAM (
-   -   paraFoam / paraview black screen (

gfilip May 11, 2009 16:02

paraFoam / paraview black screen

I received a seg. fault while running paraview and ever since whenever I try to open a case, the main view is blank and all black. There are no errors in the terminal window. I've tried to reset the camera and other settings in paraview but so far no luck.

Any ideas?


hellorishi May 12, 2009 11:59

One workaround is to use the binary from this website.

Download and extract the binary somewhere. Then add the path to that directory in your PATH variable in bashrc or tcshrc file.

You will not be able to use paraFoam. Instead foamToVTK can be used to get data in VTK format. (This typically consumes double the space on harddisk, due to duplication of data).

kjetil July 7, 2009 18:04

I would also like to know if there is any clever fix to this apart from downloading a new version. I don't understand why this shouldn't work? Also, when exiting paraFoam, my terminal outputs:


Mesa 7.4 implementation error: Unable to delete texture, no context
Please report at

... would that give any hints in what to do to solve this?

gfilip July 10, 2009 05:14

hello kjetil,

i ended figuring out a way of solving this blank screen problem without upgrading. when i load a case with a blank screen, i simply close the main display window, with the X in the upper right corner, and choose either 2D or 3D, i forget which one and cant check as i am unable to access paraview. try either one of those, and hopefully itll work.



kjetil July 12, 2009 13:57

This is a mystery.. thanks greg, but no - that either didn't work.

I then downloaded latest version from the CVS base, moved the original ParaView3.3-csv to ParaView3.3-csv-old, and moved my new CVS to use ParaView3.3-csv instead. The compiled this new paraview and the PV3-reader, it now claims to be version 3.7.0 (development), but still - it doesn't work! And what happens is ... the moment I click Apply to view the mesh/surface, the center axis disappears - and of course no geometry is seen either.

I think I even compiled a new set of Mesa drivers - version 7.4.4 - and the previous error message disappeared. But again, still no geometry.

Any clues anyone?

I'm running Ubuntu 9.04 64bit on a quad core cpu. And I compiled paraview with a "new" Qt, commenting out the error message instead of using an old Qt.

CapSizer July 13, 2009 02:01

Turn off the funky desktop effects
From your description I don't think this is your problem, but the problem I ran into sounded somewhat similar. The solution (this on Ubuntu) in my case was to turn off the funky desktop effects, things like transparant and flexible windows etc., which were messing with OpenGL.

kjetil July 13, 2009 04:30

Thanks Charles.
I am sure desktop effects are turned off too ... maybe I'll have to send a request to the paraView guys instead.

All times are GMT -4. The time now is 13:55.