CFD Online Discussion Forums

CFD Online Discussion Forums (
-   OpenFOAM (
-   -   qt4.3.4 with ubuntu 9.04 "jaunty jackalope"? (

sven May 26, 2009 20:22

qt4.3.4 with ubuntu 9.04 "jaunty jackalope"?
I upgraded my system to ubuntu 9.04 "jaunty jackalope". I need to re-compile my paraview. this is unfortunetally only possible using a qt4.3.x version of qt. so i tried tro install qt4.3.4 for ubuntu 9.04. The installation seemed to be working, but when I try to recompile paraview, I get an error, which say, that the qt version I use is qt4.5.0 and not qt4.3.4. Does anyone know if qt4.3.4. does run with ubuntu 9.04? has anyone suceeded in installing it? Thanks a lot!

tom v.d brink May 27, 2009 04:07

it worked on my ubuntu 9.04 just fine.
follow the qt4.3.4 installation completely with configure, make, make install etc (ubuntu needs a sudo to do the make install i think)
then i followed this webpage

do this:
sudo update-alternatives --install /usr/bin/qmake qmake /usr/local/Trolltech/Qt-4.3.4/bin/qmake 30

sudo update-alternatives --config qmake

and select the version you need to build paraView and the viewer.

sven May 27, 2009 13:07

Hello Tom,

tanks for your reply. Unfortunately I cannot manage to install qt4.3.4. I downloaded the qt4.3.4 archives and unpacked them. there is a file INSTALL, according to which I did the installation:
1. I can do the ./conigure (that works)
2. when i do the make command it takes about an hour until this process is finished
3. after this I tried the su -c "make install", but when I enter my password it says, that it is wrong although I am sure it is not

Did you have similiar problems installing qt4.3.4? or can you explain me the exact way you installed it? thank you so much!


akidess May 27, 2009 17:03

Sven, the admin account is disabled on Ubuntu, so "su" will always fail. Use "sudo make install" instead. That will fix problem 3.

Btw. paraview takes almost two hours to compile on my computer, so maybe start the process before you go home or during your lunch break.

sven May 30, 2009 18:22

I finally succeeded to install qt4.3.4 and with that I could also compile ParaView. the compilation took about an hour, it didnt expect it to be that long. Thanks for the help

All times are GMT -4. The time now is 08:36.