CFD Online Discussion Forums

CFD Online Discussion Forums (
-   OpenFOAM (
-   -   paraview 3.4 parallel error:got unknown argument p4pg (

carlo.dean May 28, 2009 06:18

paraview 3.4 parallel error:got unknown argument p4pg
Hi to everybody,
I'am trying to run parview in parallel, on my computer (ubuntu 8.4).
But when I run:

- mpirun -np 2 -machinefile machines pvserver

I got this error:

got unknown argument -p4pg....

I googled this error but didn't find anything.
I used mpirun in other applications so I think there are no problem whith mpirun...
Could someone help me?
Thank You

louisgag June 18, 2009 12:35

you need to compile paraview with mpi support by setting WITH_MPI=ON in the buildParaView* script

carlo.dean June 23, 2009 10:08

Thank You.
Compiling paraview setting WITH_MPI = 0 solved the problem.
But now I have another problem.
I tried to import a paralle Ensight case, but when i run it paraview seems not to load all the timesteps.
But running each part in serial mode it goes well.
What is my problem??
Is there something to specify in the .sos file for paraview???
thank you.

louisgag June 23, 2009 10:19

did you install the parallel plugins in paraview?

good luck with that.. took me a day, but got it working in the end..!

carlo.dean June 23, 2009 10:43

thank you for your reply.
As I can understand this reader is for the openFoam format?
My problem is with the Ensight Gold format.
this reader s for the Ensight Gold format too??

louisgag June 23, 2009 11:52

Hi Carlo,

that I don't know... You might have more luck asking on the paraview forum.



All times are GMT -4. The time now is 23:04.