CFD Online Discussion Forums

CFD Online Discussion Forums (
-   OpenFOAM (
-   -   Launching error with paraview 3.4.0 (

aaurouss July 3, 2009 05:54

Launching error with paraview 3.4.0

I installed paraview on Windows XP, and I there is an error when lauching

The "MSVCR71.dll" file is missing..

Has some already had this problem before ?


dipling July 3, 2009 06:01


no, but why not download it

And put it in the system or system32 dir of XP ?

aaurouss July 3, 2009 10:55

Thanks, it works.

But now I have another problem:

I run the OpenFoam tutorials on a Linux system and use Paraview with Windows. I can mount the Linux directory to read the tutorial data from Windows. But i can't open the .foam files, i don't find them ...It seems that the visualization with paraview on windows is different than using it under Linux...

Has anyone know smthg about that ?

dipling July 6, 2009 17:29

What do u mean with .foam files ? But i think u solved the problem now :)

aaurouss July 7, 2009 09:01

It's possible to generate .foam files (which are called 'dummy files' in the user guide).
It's necessary when you need to open the OF case manually with ParaView. When launching the case with Linux ParaView, the OF script paraFoam generates such a file, "gathering" the datas from the different files and sub-directories. But this file isn't available to open so we need to create one.

aaurouss July 7, 2009 09:03

And yes my problem is solved now :)


actone July 16, 2009 11:29

hello everyone,

i have the same problem. Can you create .foam files using windows?

aaurouss July 16, 2009 11:37

If you have the same problem, then I may have an answer now. You have to generate .VTK files that are readable by paraView using the command "foamToVTK" in the case directory.

actone July 16, 2009 12:00

Thanks for your very fast answer!
I tried this, but there is still a problem, i can see the vtk file in the "pipeline browser" but i have an error when i want to apply:

ERROR: In C:\tmp\OpenFOAM-1.5\3rdparty\ParaView-3.4.0\VTK\IO\vtkUnstructuredGridReader.cxx, line 350 vtkUnstructuredGridReader (0x1f50d738): Unrecognized keyword: o>€$<w:o>‚< ::o>„h<œ:o>†)<™z:o>ˆs<–$:o>Š“[<’„t:o>Œi<Ž:o>v<Š™:o>‘@<†w:o>”z<‚ Š:o>u

but maybe that is a very basic problem since i just installed Openfoam

actone July 20, 2009 05:23

it seems that it comes from the foamtovtk command on windows, because i solve my problem, it propely works. I also tried to solve on a linux computer then do foamtovtk on linux and transfer it on my mindows and it works.

any idea?

aaurouss July 20, 2009 08:51

Bon je vais rpondre en Anglais, par politesse pour ceux qui veulent lire le post !

Your methodi is the same I'm using, and it seems to be working properly .

So the problem is solved, isn't it ?

Bon courage

actone July 20, 2009 09:02

the problem is fixed by typing: foamtovtk -ascii ...

thank you

padmanathan August 4, 2009 02:04


i'm also facing the same problem, can you tell me where we have to change foamtovtk-ascii?

thanks & regards


Originally Posted by actone (Post 223308)
the problem is fixed by typing: foamtovtk -ascii ...

thank you

actone August 4, 2009 10:44

after the blockmesh command, type foamtovtk -ascii, into the same folder. Then it will create a vtk folder with .vtk files inside, that you will be able to open with paraview.

does it works?

padmanathan August 5, 2009 00:57

hi Antoin,

thanks for your reply, it is working fine for me.

what i tried is, though i'm using windows OpenFoam, after giving blockmesh, by right clicking on foamToVTK and in customize write as
"foamToVTK -ascii" and close. then, in foamToVTK right click and run start custom.

that's it.

thanks & regards,

All times are GMT -4. The time now is 02:14.