CFD Online Discussion Forums

CFD Online Discussion Forums (
-   OpenFOAM (
-   -   QT4 assiatant installation (

aliakbar82 November 14, 2009 08:43

QT4 assiatant installation
I want to install OpenFOAM 1.6 H have done evey thinh ountill the part i shoude install QT4 assiatant but this computer that i work with can not connect to internet and its installation needs connecting to internet. So I do not how to downloal QT4 assiatant using another computer and how to install it to solve my problem.

gwierink November 15, 2009 03:29

  • You can get the Qt-4.3.5 source from here
  • Download it, copy it to the computer you need it on
  • Then unpack it

    tar -xzf qt-x11-opensource-src-4.3.5.tar.gz
  • Configure Qt

  • Make Qt (as root)

  • And install it

    make install

aliakbar82 November 16, 2009 03:02

qt installation
Thank you for answer but it does not work completely.I did all you said ,unpacking Qt-4.3.5 then Configuring Qt,but when I ran make command I saw a lot of warnings and erors such as:

../../include/QtCore/../../src/corelib/tools/qbytearray.h:398: warning: type qualifiers ignored on function return t
../../include/QtGui/private/../../../src/gui/kernel/qt_x11_p.h:310: error: ‘Window’ has not been declared
make[1]: *** [.obj/release-shared/qapplication.o] Error 1
make[1]: Leaving directory `/home/ali/qt-x11-opensource-src-4.3.5/src/gui'
make: *** [sub-gui-make_default-ordered] Error 2

but after them I ran make install and this messages appeared:
mkdir: cannot create directory `/usr/local/Trolltech': Permission denied

make[1]: *** [install_target] Error 1

make[1]: Leaving directory `/home/ali/qt-x11-opensource-src-4.3.5/src/tools/moc'

make: *** [sub-moc-install_subtargets-ordered] Error 2

I dont know how to solve this problem.who can help me?

gwierink November 16, 2009 13:12


/usr/local/Trolltech': Permission denied
You get that message because your user (you) does not have write permission in /usr/local/... You need to be root for that, i.e. type "su" before "make" and "make install" (or "sudo make" and "sudo make install" I guess) and give your root password.

Sajjad_Baraty July 23, 2012 15:24

i have this problem.please help

wyldckat July 23, 2012 16:47

Greetings Sajjad Baraty and welcome to the forum!


Originally Posted by Sajjad_Baraty (Post 373064)
i have this problem.please help

Please provide more details:
  1. What Linux distribution are you using?
  2. What exact error message are you getting?
  3. Which instructions have you followed?
Best regards,

Sajjad_Baraty July 23, 2012 17:52

thank you.
i use fedora 16.
and the exact error is (the 2 last line) :
make[1]: *** [.obj/release-shared/qsslcertificate.o] Error 1
make[1]: Leaving directory `/home/sajjad/OpenFOAM/ThirdParty-2.1.0/qt-x11-opensource-src-4.3.5/src/network'
make: *** [sub-network-install_subtargets-ordered] Error 2

wyldckat July 23, 2012 18:16

The instructions on this thread are seriously outdated if you are using Fedora 16 and OpenFOAM 2.1.0.
Here more recent instructions, although they are also becoming outdated by now: Building ParaView 3.10.1 with custom Qt 4.6.4
Adapt where necessary for using ParaView 3.12.0, but I advise you to still use Qt 4.6.4.

Best regards,

All times are GMT -4. The time now is 22:52.