CFD Online Discussion Forums

CFD Online Discussion Forums (
-   OpenFOAM (
-   -   Problem OpenFOAM/Paraview (cavity tutorial) (

vianne December 11, 2009 08:04

Problem OpenFOAM/Paraview (cavity tutorial)
Hi to all,

I'm a newbie working with both Linux and OpenFOAM just since a few days so my question might be an easy one for you :)
I use Ubuntu Linux 9.10, OpenFOAM 1.6, Qt 4.5.2 and I have the following problem: As described in the cavity case tutorial, I try to create a block mesh and view the mesh in ParaFoam. There are no errors during the creation of the block mesh and the cavity.OpenFOAM file, but I can't see the mesh in the opened ParaView window (I checked the box Mesh Parts, the box Volume Fields and the field Cache Mesh, then I clicked the Apply button, after that I set Colour by Solid Colour, clicked Set Ambient Colour (selecting black), selected Wireframe, Parallel Projection and a white backround colour).
It would be really great if anyone had an idea why there's no mesh appearing.

SirWombat December 11, 2009 11:22

Hi Vianne,

you might wanna try the following:

before starting "paraFoam" type the following at the command line:
export LC_ALL=C

You may also edit the "paraFoam" File in

Just place "export LC_ALL=C" in the first line of the file.

Sony Vaio VGN-FW11J Core2Duo P8400 2,26Ghz 4GB ATI Mobility Radeon HD3650
Ubuntu Linux 9.10, OpenFOAM 1.6, Qt 4.5.2

vianne December 11, 2009 15:01

Thanks a lot, now it works and I would have never solved this on my own ;)

eros January 8, 2010 17:44

paraFoam locks
Hi I loaded OpenFOAM-1.6 and try cavity example with to precompiled binaries.
My system is Ubuntu dapper, so QT is too old -> download and recompile QT, paraview + plugin. After that cavity example paraview stage starts, but viewer stuck immediatly. After that no window refreshing and it consume 99.9% cpu. I give it one hour try but only affect is slight more memory consuption up 156MB.

export LC_ALL=C don't help either. Is there known solutions? Recompile all? (paraview - QT broblem? can recompile all help?)

Maybe google more solutions, this thread was first hit..


SirWombat January 12, 2010 04:16

no idea
Hi Eerin, unfortunately I don't have a solution to your problem. It might come handy to post version numbers making it easier for anyone else to give you a hand on that!

deka January 19, 2010 05:32

Hi SirWombat,
Thanks for the tips. It also works for me too. I also use ubuntu 9.10, OpenFOAM 1.6 and Qt 4.5.2. Is it a common case?

Jose88 February 18, 2010 14:24

Problem in file (cavity)

I am a new user in Linux and OpenFOAM 1.6. I have a small problem and I dont why. I really appreciate if you can help soon. When I am trying to run or create the mesh with blockMesh for the "cavity" problem and others there is a file that is not found. it says:

[ytp0106@n1 cavity]$ blockMesh
blockMesh: error while loading shared libraries: cannot open shared object file: No such file or directory

what do you think could be the problem? Actually I dont know what is that file. but, I am sure i am in the right directory. I hope you can help me.

Thank you.

wyldckat February 20, 2010 07:34

Greetings Jose88,

Seems to me that you didn't unpack the ThirdParty package, the ThirdParty-1.6.linuxGcc.gtgz or ThirdParty-1.6.linux64Gcc.gtgz

The library is part of the openmpi software available in these packages above.

Did you follow the instructions available at or did you follow Mads cookbook for Ubuntu (available here)? If followed neither one, then it's only natural that your installation is missing some stuff ;)

Additionally, stating which Linux version/distro your using might help in future issues.

Best regards,
Bruno Santos

Jose88 February 20, 2010 07:52

Hi Bruno,

Thank you for your answer. I will take into account your advice. I think that something could be missing from the installation as you said.

Thanks for the links.. :)

Kind Regards,


All times are GMT -4. The time now is 10:13.