CFD Online Discussion Forums

CFD Online Discussion Forums (
-   OpenFOAM (
-   -   How to define patches after gmshToFoam ? (

seb_j February 3, 2010 06:40

How to define patches after gmshToFoam ?

I made a 3D model in gmsh and then export it with gmshToFoam.

In gmsh I have defined the tags of my boundary with "Physical faces", but these tags seems to go away after the use of gmshToFoam.

So I have to define my physical boundary as patches in the boundary file of openfoam -> I need to know the total number of face and the first face of each of my boundary.

Is there a simple way these datas in paraFoam ? Maybe a way to select a boundary with the mouse and get the datas ? Or an ohter way to define my boundaries ?

Thanks a lot for your help,

Best regards

dfransos February 8, 2010 07:04

I usually define boundaries as

Physical Surface("name") = {number};

in gmsh and it works fine with gmshToFoam.
Could you post your .geo file?

moser_r July 5, 2011 08:32

1 Attachment(s)
I have exactly the same problem with the surfaces not being translated into boundaries after using gmshToFoam. I have attached an example that I found on the forums which worked for other people, but not for me (using OpenFOAM 1.7.1 and gmsh 2.5.0). Any ideas?

pcaron July 5, 2011 09:36

Hello Davide and Richard, same problem here. I have used gmsh for about a year.

I reinstalled my OS recently (opensuse 11.4 64 bit) I could not find out how to get gmsh 2.5 and OF-1.6-ext working together.

I solved the problem downgrading to gmsh 2.4.2. It works perfectly now.

I hope this can help you.



murrdpirate July 5, 2011 15:43

Gmsh 2.5 with OpenFOAM 1.7.1 work for me. Also works with OpenFOAM 2.0. Although I haven't had this exact issue, I have had issues in the past and found that the wrong settings in gmsh can mess everything up. Here's the Mesh options that work for me, might wanna try them out:

moser_r July 7, 2011 02:27

Many thanks Pablo. Using the latest nightly build of gmsh (2.5.1) sorted the problem for me, and all the patches now come through to OpenFOAM.

pcaron July 12, 2011 17:46

Hello Richard, sorry for the late reply.

I downloaded the nightly source code yesterday and I still could not get my patches in openfoam. :(

Did you download the source code or the precompiled version?

Using this source code I solved a problem related with opencascade (a missing header) but I still have the patches related issue. I tried the msh file in other openfoam installation and the problem persist.

Any ideas?



moser_r July 13, 2011 02:38

I was using the pre-compiled version under Windows (haven't yet tried it under Linux).

If you attach your .geo file I could have a go and see if it works with my system, if you like.


pcaron July 13, 2011 09:25

Hello Richard,

You can follow this link to download the files

p, li { white-space: pre-wrap; }

It is a very simple geometry. A L shaped domain in 2D. There are 3 files, the geo file, and 2 msh files, generated with gmsh 2.4.2 and 2.5.1. The one generated with 2.5.1 version does not generate the patches from the physical surfaces.

Thank you for your help


All times are GMT -4. The time now is 01:05.