CFD Online Discussion Forums

CFD Online Discussion Forums (https://www.cfd-online.com/Forums/)
-   OpenFOAM (https://www.cfd-online.com/Forums/openfoam/)
-   -   Yet another Paraview problem (https://www.cfd-online.com/Forums/openfoam/72402-yet-another-paraview-problem.html)

gascortado February 4, 2010 10:24

Yet another Paraview problem
 
Hi.

After spending a month worth of evenings trying to get OpenFOAM running I will appreciate if anyone can help. Let me describe my problem:

I succesfully installed OpenFOAM in my system with Ubuntu 9.10. I tested my installation and there is no errors of any kind. BlockMesh and icoFoam run with no problem.

Then the usual problem, when I typed paraFoam the "command not found" appeared. Thru forums I try to install the right version of Qt with no luck. I decided then to download and install the new version of Paraview 3.6.2.

I succesfully installed paraview 3.6.2 but when I type paraFoam the follwoing happens:

GLIBCXX_3.4.11' not found (required by /usr/lib/paraview/libvtksys.so.pv3.4)

Paraview opens when I browse to the ThirdParty folder and I excute the paraview executable file. However paraFoam command does not work.

any help will be greatly appreciated. Thanks

thekay February 5, 2010 08:56

I believe you are missing a link from the ThridParty libstdc++ to where paraFoam looks for the files.

In another thread, piprus suggested this:


Code:

cd /home/USER_NAME/OpenFOAM/ThirdParty-1.6.x/gcc-4.3.3/platforms/linux64/lib64

sudo mv libstdc++.so.6 libstdc++.so.6.orig
sudo ln -s  /usr/lib/libstdc++.so.6.0.10 libstdc++.so.6

sudo mv libgcc_s.so.1 libgcc_s.so.1.orig
sudo ln -s /lib/libgcc_s.so.1

Modify accordingly and try the above.

Hope it helps.

gascortado February 5, 2010 09:58

Thanks for your reply. I'll try that tonight and I will let you know if it helped

gascortado February 12, 2010 15:08

Hi. I finally tried and it did fixed the problem However, I have another problem:
When I run paraFoam, para view ask me to specified the type of file. no matter what I select, paraview crashes and I get the following error:

terminate called after throwing an instance of 'std::length_error' what(): basic_string::_S_create Aborted

I also noticed that at the top of the paraview vindow, it says "Kitware 3.4.0". Isn't it supposed to say 3.6.1 or something?

Any help will be greately appreciated!

Thanks

thekay February 15, 2010 09:43

Should be 3.6.1 as you say. Are you sure you have downloaded and installed the latest version?

How was the previous problem fixed?

anmartin February 21, 2010 07:39

I have had the same problem and after many trials and error finally i can install correctly OF in ubuntu 9.1.

1 download all archives, and follow instruction from readme file
2 edit bashrc (gedit $Home/.bashrc) and copy the test showed in instructions.
3 update variables
4 write "export LC_ALL=C" at the beginning of your paraFoam Startskript (which paraFoam) (http://www.cfd-online.com/Forums/ope...-paraview.html)

no more needed,


All times are GMT -4. The time now is 17:36.