CFD Online Discussion Forums

CFD Online Discussion Forums (
-   OpenFOAM (
-   -   ParaView segmentation fault only for multiphase (

gwierink February 27, 2010 15:11

ParaView segmentation fault only for multiphase
Dear all,

I installed OpenFOAM-1.5-dev on Ubuntu 9.10 x86_64 and it all works swell, also paraFoam. That is, for single phase cases. When I run a multiphase case like damBreak or bubbleColumn paraFoam crashes with a segmentation fault. No error messages are given :(. When I convert the case to VTK and open it in ParaView, it still crahses with a segmentation fault. ParaView does give some error messages, although I can't really tie them to crashing for multiphase:


Fontconfig warning: "/etc/fonts/conf.d/11-lcd-filter-lcddefault.conf", line 9: invalid constant used : lcddefault
Fontconfig warning: "/etc/fonts/conf.d/53-monospace-lcd-filter.conf", line 17: invalid constant used : lcdlegacy
Segmentation fault

Does anyone have an idea what can cause this? Should I recompile the whole lot? Thanks in advance!

sega February 28, 2010 06:39

Is there a debug-switch for paraFoam?
If so, try to switch it on, and maybe you will get a more detailed error message.

gwierink March 4, 2010 03:48

Hi Sebastian,

Thanks for your reply. I don't know whether there is a debug switch in paraFoam. There probably is one, but haven't found it yet :). I did some further digging and found that there is a problem with the graphics driver ( It turns out that my work laptop has an ATI card and I read on the Ubuntu wiki that I should grab the latest kernel and find the Ubuntu open source driver for my ATI card. I did that, but no success. I also installed OpenSUSE-11.2 on the same laptop to see if it works, but no success either :(. Does anybody have experience of how to get ParaView working properly on a Lenovo W500 (ATI Radeon HD3650 DX10.1)?

sega March 4, 2010 03:54

I had some problems regarding the graphics drivers, too.
Just installing a new kernel and/or graphics driver didn't work out on my system.
I even had to recompile ParaView and the PV3FoamReader again.

gwierink March 4, 2010 03:58

Ok, so the recipe of

  1. grab new kernel
  2. install open source driver
  3. recompiling ParaView
  4. recompile PV3FoamReader

sega March 4, 2010 04:10

On my Ubuntu system this worked!

gwierink March 4, 2010 04:21

With an ATI card? That would be great news!

sega March 4, 2010 04:41

I can't promise you THAT, but I made the experience, that changing drivers/kernels does not effect the current compilation of ParaView and the reader. I had to do it again ...

gwierink March 4, 2010 04:44


I can't promise you THAT
That's a pity ;). I didn't recompile ParaView after installing the new driver, so I'll do that and see what happens. Thanks for your help :).

gwierink March 25, 2010 08:23

Kind of solved
This is just a message to log what I got working. Hopefully of some use to someone.

After some struggle with Ubuntu and OpenSUSE it got "kind of solved" :). At the moment I have OpenSUSE 11.2 installed and it works very well. The main problems were (are) with the graphics card. I changed two things that got it working:
  1. Install ParaView-3.4.0 instead of 3.6.2
  2. Change the default graphics card in the BIOS
In the BIOS "config" > "display" section there are three values, these are the one that worked for me:
  1. Default graphics card: "integrated" (was ATI)
  2. Integrated/discrete graphics: "let OS choose" ("integrated" worked as well)
  3. OS detection: "enabled" (but both "enabled" and "disabled" worked)
I guess the trick was to switch to integrated graphics card as default and use ParaView-3.4.0 ... Anyways, I'm happy it works now :D. Thanks, Sebastian, for your help.

All times are GMT -4. The time now is 22:56.