CFD Online Discussion Forums

CFD Online Discussion Forums (
-   OpenFOAM (
-   -   ParaView Stopped Working (

AlanR April 16, 2010 01:58

ParaView Stopped Working
My ParaView suddenly stopped working tonight. I'm running OF 1.6.x on Ubuntu 9.10 64 bit. I installed everything months ago and looked at dozens of OF files in ParaView since the installation. I did not add anything to my system or update any packages today. A few hours ago I was experimenting with snappyHexMesh settings. About the 10th time I typed paraFoam to look at a mesh, ParaView opened to a blank screen (the first 9 times were OK, everything opened normally).
I have tried restarting OF, restarting my system, re-installing several Qt libraries via Synaptic, updating (git pull) OF 1.6.x and recompiling, removing and recompiling ParaView and recompiling PV3FoamReader. FoamInstallationTest results are OK, and there were no compile errors. I tried foamToVTK, but those files won't open either. :confused:

So far, nothing has worked. After the paraFoam command, ParaView opens with a blue screen and axes. The pipeline browser window shows mydir.OpenFOAM and nothing below it (no Apply button, no patch list, nothing). Any advice will be greatly appreciated.


wyldckat April 16, 2010 07:19

Greetings Alan,

You said that:

I tried foamToVTK, but those files won't open either.
Just to be certain of what you said, does that mean that:
  • foamToVTK did create the folder VTK and created the *.vtk files inside that folder;
  • when you start Paraview and open specifically either one of those created "VTK/*.vtk" files, and pressed in the Apply button, none of them appeared in Paraview, not even scalar/vector entries, not even the bounding box.
Or, does the Apply button not appear? Not even the window area where it use to be?

Best regards,

AlanR April 16, 2010 17:33

foamToVTK created a VTK folder with files in it. I opened the folder in Paraview, but there was no Apply button. ParaView does not appear to see any files, not even files that I know I was viewing an hour before the problems started. My normal process is just to use paraFoam. I thought recompiling Paraview should work, but it didn't.

wyldckat April 16, 2010 19:16

1 Attachment(s)
Hi Alan,

OK, so if I'm understanding this straight, you can open the *.vtk files, they show up on the pipeline browser, but no Apply button shows up. My guess is that you aren't seeing the "Object Inspector" widget - it's the one that shows the control options for the selected open file. In other words, what you are probably seeing is like in the picture that I attached.

So, to fix this, on Paraview's "View" menu, check the box that says "Object Inspector". The widget should now show up once again and show the "Apply" button!

If the Object Inspector doesn't show up, or if it's visible but doesn't show the Apply button, try running this command, after closing all Paraview windows:

rm ~/.config/ParaView/ParaView3.6.ini
This will erase your user configuration file for Paraview, thus reseting Paraview to factory values, thus making all of the usual Paraview components visible once again. NOTE: This will not require rebuilding Paraview! ;)

Hopefully this will fix the problem. If not, please post a picture of what you are seeing, since it will help to get a better view of what you are seeing ;)

Best regards,

AlanR April 17, 2010 00:59


Muito obrigado! I thought my problem wast be something like Paraview getting set in some strange configuration. Your reset command did the job. If you ever visit Idaho, I'll buy you dinner and a beer or two. Ter um grande fim de semana.
Best regards,

wyldckat April 17, 2010 04:55

Hi Alan,

You're welcome! I'm glad I could be of some help :) And thank you very much for the dining offer!

By the way, I remembered that another possibility was that the "Objector Inspector" widget got accidentally merged with another widget. If you drag-and-drop the widgets (sort of like sub-windows) in Paraview, some of them just merge the two widgets and become a single sub-window with multiple tabs on the bottom of that sub-window.

Ah, and a good weekend to you too :)
Best regards,

All times are GMT -4. The time now is 15:38.