CFD Online Discussion Forums

CFD Online Discussion Forums (
-   OpenFOAM (
-   -   icoFsiFoam on OpenFOAM 1.6 (

waku2005 June 1, 2010 15:34

icoFsiFoam on OpenFOAM 1.6
Hi all,

Does anyone can compile icoFsiFoam on OpenFOAM 1.6 ?
Please tell me how to compile it or modifications related to the successful compilation.

I compiled successfully icoStructFoam on the 1.6 and seems to get fine results of two test cases attached the icoStructFoam, but hope to use icoFsiFoam.

Thanks in advance.


vkrastev June 18, 2010 11:18

Hi Waku, I've also compiled icoStructFoam on OpenFOAM-1.6, but I have some problems with the matter of running the blockMesh utility for both of the regions of the thingOnStick test case. Could you please give me some advices about it?

Thanks in advance

waku2005 June 19, 2010 01:46

Hi, vkratev,

I've used the icoStructFoam downloaded from, and it works fine.

Instructionsof the icoSructFoam described in the openfoam wiki will works good
in the thingOnStick test case which was attached to the above tar-ball.

Here's my steps to run IcoStructFoam:
> tar zxvf IcoStructFoam_Rev561
> cd coStructFoam_Rev561
> cd icoStructFoam (wmake in this directory)
> cd ../
> pwd
> /home/ofuser/OpenFOAM/ofuser-1.6/my_orig/IcoStructFoam_Rev561
> ln -s region1/polyMesh/ thingOnStick/constant/polyMesh
> blockMesh -case thingOnStick
> rm thingOnStick/constant/polyMesh
> ln -s region2/polyMesh/ thingOnStick/constant/polyMesh
> blockMesh -case thingOnStick
> rm thingOnStick/constant/polyMesh
> cd thingOnStick
> icoStructFoam (It will run successfully without any editing dictionaries)

I've read in the E.Mogura's Blog (Japanese site) that icoStructFoam from the openfoam wiki could not be compiled on OF 1.6.

tdalla June 24, 2010 03:36

Hi, I'm also interested to compile the icoFsiFoam for the version 1.6. I will try to compile the one from the version 1.5....

karlmaus June 28, 2010 07:07

Hi, all.

As far as I understand it (please correct me if I'm wrong, anyone :)), the icoFsiFoam solver from the extend-project depends on several parts not present in the official version of OpenFOAM (OF), most notably the tetrahedral finite element routines.

The reason for this is that for a proper fluid-structure interaction (FSI) solver you would want the interface boundary to be calculated as correct as possible, hence the nodal (vertex) -based solution method of tetFEM for the mesh and thus the boundary.
To use only the cell-centered finite volume method (FVM) in OF could result in incorrect boundary calculations and wrong mesh motion (e.g., non-conserved volumes, wrong motion of boundary due to interpolated solid velocities, etc.).

Another approach would be to use a vertex-based FVM, but AFAIK this is not present in OF (yet).

Marta October 11, 2010 09:53

Hi All! I've just downloaded and compiled successfully IcoStructFoam for 1.6 OpenFoam version. The run didn't show any problems, but i have some difficulties in visualising the results with paraview.

What happens is that when i try to convert the format using foamToVTK command, it says it cannot find points file, which is obvious, since thi file is not inside the constant directory, but in region1 and region2 folders.
Do you have any ideas about how i can solve the problem for postprocessing?

Thanks a lot


PeterII December 24, 2010 07:33

icostructFoam paraFoam
Hi Waku, I've compiled icoStructFoam on OpenFOAM-1.7.1, but I have some problems with running the paraFoam utility for both of the regions of the thingOnStick test case. Could you please give me some advices about this?

waku2005 December 25, 2010 21:28

Hi, khaled

I've just compiled and run the case on OF-1.7.1, successfully.
For visualization, paraFoam showed error such fv*** files not found in ./system directory, but I think this error is not so serious.

How about check two workarounds below:
1) Use formToVTK
> foamToVTK -region region1
> foamToVTK -region region2
> paraview (paraFoam)
Please use Warp filter with vector D to see region2 deformation.

2) merge fvSolution and fvSchemes files in two regions and set ./system directory
Sorry, I've not fully tested yet, but after just copying fv*** files in region1 into system directory, paraFoam works good.


PeterII December 27, 2010 12:09

Hi Waku,
thank you so much for this information. I compiled with success the case thingOnStick but I cannot compile the second example icoStructFoamTest and I receive the following error:

patch type 'wall' not constraint type 'symmetryPlane'
for patch top of field D in file "/home/khaled/OpenFOAM/khaled-1.7.1/applications/solvers/IcoStructFoam_Rev561/icoStructFoamTest/0/region2/D"

file: /home/khaled/OpenFOAM/khaled-1.7.1/applications/solvers/IcoStructFoam_Rev561 /icoStructFoamTest/0/region2/D::boundaryField::top from line 43 to line 43.
From function symmetryFvPatchField<Type>::symmetryFvPatchField
const fvPatch& p,
const Field<Type>& field,
const dictionary& dict
in file fields/fvPatchFields/constraint/symmetry/symmetryFvPatchField.C at line 99.

FOAM exiting

please anny help

thank you in advance

best Regards

waku2005 December 27, 2010 20:57

Hi khaled,

Error message show you that there is somthing wrong in "top" patch of region 2.
Edit constant/region2/polyMesh/boundary file like below and please run again.

> vi constant/region2/polyMesh/boundary

// type wall;
type symmetryPlane;
nFaces 60;
startFace 4760;

Hope this helps you.
best regards,

PeterII December 31, 2010 19:01

hello waku,

thanks for your very useful suggestions. I would like to do simulation of blood flow including fluid-structure interaction. I'm trying to install icoFsiFoam on OpenFOAM 1.7.1.
Thanks in advance for any suggestions

fatemeh.sadeghpour October 17, 2012 04:28

Hi khaled
has your problem solved?i cant run icoStructFoamTest in oF 2.1.1 , it has a lot off errors like:

when i use:
ln -s region1/polyMesh/ icoStructFoamTest/constant/polyMesh

it reply:

create time

Cannot open mesh description file

From function blockMesh
in file blockMeshApp.C at line 148.

FOAM exiting

and when i use the command :
foamToVTK . icoStructFoamTest -mesh region1

it reply:

Create time

Create mesh region1 for time = 0

cannot open file

file: /home/sadeghpour/OpenFOAM/sadeghpour-2.1.1/run/tutorials/icoStructFoamTest/system/region1/fvSchemes at line 0.

From function regIOobject::readStream()
in file db/regIOobject/regIOobjectRead.C at line 87.

FOAM exiting

please someone help me what should i do?

ziemowitzima February 14, 2013 15:14

icoStructFoam, where is mesh.update() ??
I am working currently on a solver with moving mesh. Actually one boundary is changing according to solution of other equation.
I implemented mesh changes same as in icoSructFoam solver. But to update my mesh I need to add following line:
HTML Code:

which is not included in icoSructFoam...

I am confused because my mesh is not get updated without this command, but mesh in icoSructFoam is updated...

Moreover my solution, after mesh is updated, behaves somehow strange.

I hope anyone will have any suggestions.


ziemowitzima February 14, 2013 18:27


HTML Code:

is not a problem anymore, I found the differences between my solver and icoStructFoam. Now it works both with and without "mesh.update();".

But I still have the problem with energy being added to the system after mesh is changed.
It happens for simple diffusion equation:
HTML Code:

fvScalarMatrix omEqn
      - fvm::laplacian(dimensionedScalar("1",dimensionSet(0, 2, 0, 0, 0),1), om)

if mesh does not change, or change only "a little" then it behaves as diff equation, namely field "om" diffuses out, and getting weaker.
But if mesh is changed "little more than a little" then "om" gets stronger and stronger with each time step...

Do you have any clue why it is like that ??


All times are GMT -4. The time now is 08:57.