CFD Online Discussion Forums

CFD Online Discussion Forums (
-   OpenFOAM (
-   -   Installing openfoam 1.7 on opensuse 11.2 (

navarrom June 30, 2010 17:35

Installing openfoam 1.7 on opensuse 11.2

I have installed OpenFOAM 1.7 on opensuse 11.2. Performed the installation test, everything checked out ok. However, when I go to run the first tutorial as follows:

Run the first example case of incompressible laminar flow in a cavity:

cd $FOAM_RUN/tutorials/incompressible/icoFoam/cavity

I get the following message:

/home/navarrom/OpenFOAM/OpenFOAM-1.7.0/bin/paraFoam: line 132: paraview: command not found

Did I miss a step in the install?

wyldckat July 1, 2010 08:15

Greetings Navarrom and welcome to the forum!

Well, apparently you didn't fully follow the installation instructions!
There are various instructions you can follow:
Best regards,

navarrom July 1, 2010 10:19

Thank you Wyldckat, for taking the time to greet me to the forum. During the install I was referencing the OpenFOAM 'readme' file and Alberto's tutorial "how-to's OpenFOAM 1.7 - openSUS 11.2". That got me far, but I must have made a wrong turn somewhere. I will try the other two installation tip leads you posted.



cwang5 July 5, 2010 06:36


I'm actually having the same problem with paraview installation, I get these lines at the end of ./makeParaView command:


make[2]: *** [Documentation/paraview.qch] Error 127
make[1]: *** [Documentation/CMakeFiles/ParaViewOnlineHelp.dir/all] Error 2
make: *** [all] Error 2
    Installation complete for paraview-3.8.0
    Set environment variables:

        export ParaView_DIR=/home/john/OpenFOAM/ThirdParty-1.7.x/platforms/linuxGcc/paraview-3.8.0
        export PATH=$ParaView_DIR/bin:$PATH
        export PV_PLUGIN_PATH=$FOAM_LIBBIN/paraview-3.8

Since the error was pointing to some online help documentation, I assumed that it wouldn't effect the actual operation, but I was wrong. I received the same "command not found" error as in the first post, and upon following Alberto's guide (which also stated that he was having problem setting up the paraFoam to work out of the box for OpenSUSE 11.2), I received the following error when running the SVN version of the reader:


CMake Error at CMakeLists.txt:22 (FIND_PACKAGE):
  Could not find module FindParaView.cmake or a configuration file for
  package ParaView.

  Adjust CMAKE_MODULE_PATH to find FindParaView.cmake or set ParaView_DIR to
  the directory containing a CMake configuration file for ParaView.  The file
  will have one of the following names:


 CMake Error at CMakeLists.txt:23 (INCLUDE):
  include called with wrong number of arguments.  Include only takes one

 CMake Error at CMakeLists.txt:33 (MESSAGE):
  ParaView version .  is too old.  The package only supports ParaView 3.8 or

The only ParaViewConfig file I could find in the ThirdParty directory was, which apparently does not work. I'm not quite sure what the problem is at this point, and would appreciate any help from the forum.



navarrom July 5, 2010 11:37

Thanks for your input John, nice to know I am not the only one with the problem. I also get the message you posted for the 'Third party' install when I follow Alberto's tutorial. I am considering changing my OS from opensuse to ubuntu, and just downloading the compiled ubuntu version.

Bufacchi July 5, 2010 12:41

I used the precompiled version available at, and did the tweak described in the second half of the post: Installation paraFoam - still problem.

It works fine.


cwang5 July 12, 2010 08:25

It turned out that installing the qtwebkit-devel package in 11.2 solved the problem for me.


navarrom July 12, 2010 11:47

It turned out that installing the qtwebkit-devel package in 11.2 solved the problem for me.

So, when you installed qtwebkit-devel, did you recompile Paraview? Did you still have to follow 'Alberto' instructions?



All times are GMT -4. The time now is 12:09.