CFD Online Discussion Forums

CFD Online Discussion Forums (
-   OpenFOAM (
-   -   Segmentation fault when visualizing in ParaView (

fsalvucci July 8, 2010 11:20

Segmentation fault when visualizing in ParaView
HI Everyone!! I have this problem. I installed the latest release of OpenFoam (1.7) in Linux 10.4. Everything works good, except when i go to ParaView. I excecute paraFoam, and ParaView runs correctly. When i select some part of the mesh and click "Apply", it closes and i gete the error:

Segmentation fault.

And thats it, it doenst work for any mesh, for any case.

Any ideas?


wyldckat July 8, 2010 19:59

Greetings Fernando,

OK... firstly, is Ubuntu 10.04 is a Linux distribution ;)

Now, as for the issue you are getting... What were exactly the steps you did before running paraFoam? Did they include either one of these commands:



If not, don't expect to have a ghostly mesh, because OpenFOAM doesn't do ectoplasm... or at least I don't think it does :D

Are you following OpenFOAM's official User Guide? See here:

I'm sorry for seaming a bit goofy in my answer, but with the information you provided, I can only infer that the steps you took prior to running paraFoam were the wrong ones, if any :(

Best regards,

fsalvucci July 12, 2010 11:17

Ok, maybe i didnt give too much details.
I have been using openfoam for some time. The thing is that last week i installed it on a new server we boguht. What i am trying to do works perfectly in another computer.
I use meshes cretaed by netgen and correctly exported to openFoam. Before trying to run paraFoam, i run the simpleFoam solver, with the correct bounday conditions and everything ok. In any other computer, with OpenFoam 1.6 i can visualize results with paraFoam.

Now, in this new installation, with this new version 1.7, in Ubuntu 10.04, i get this problem. Not only with my cases, but with any tutorial.

Any ideas?

wyldckat July 12, 2010 17:57

Hi Fernando,

OK, what versions of OpenFOAM and of ParaView did you install? Was it:
  1. Downloaded sources and built both OpenFOAM-1.7.0 and ParaView-3.8.0.
  2. Used the pre-built debian packages, both openfoam170 and paraview380.
  3. Used Ubuntu's ParaView 3.6.?.
  4. Used the pre-built version
Now, another question: is your Ubuntu installation in English or in Italian/French/other? If not in English, did you do the "export LC_ALL=C" trick?

Because "segmentation fault" could be from many things:
  1. Bad graphic card drivers - sometimes the previous version works better then the most recent one;
  2. Missing libraries and no relevant message is shown;
  3. Conflict of libraries (in the past, some users had problems with the OpenFOAM plugins for ParaView, because for some reason, ParaView loaded a version of libc and OpenFOAM used another);
  4. Problems with the local language being incompatible with the expected English version. Usually the problem is related to what sign is used to separate units from decimals.
  5. There is a hidden folder on the user's home folder that saves the configurations for ParaView, which sometimes messes up ParaView.

So, the better you can describe the steps you took to install OpenFOAM, the better chances are that we can isolate the actual problem!

Best regards,

fsalvucci July 13, 2010 14:49

Hi! Thanks a lot! I tell you.
Ubuntuīs installation is a fresh clean one, downloaded form Ubuntus webpage installed as 64 bits in ENGLISH.
For openFoam and paraView installation, i followed all the steps in:

I guess that would be the ones with openfoam170 and paraview380.

And thatīs it.

Once the installation was completed, i tested it with one tutorial and with one of my cases and it worked. After restarting, ir didnt work anymore.

Thanks a lot, i am a bit stucked with work :(


wyldckat July 13, 2010 17:55

Hi Fernando,

Originally Posted by fsalvucci (Post 267103)
Once the installation was completed, i tested it with one tutorial and with one of my cases and it worked. After restarting, ir didnt work anymore.

OK, if it stopped working after restarting the computer/Ubuntu, that means that possibly you also updated Ubuntu and/or installed the latest graphic card drivers before rebooting. Additionally, Ubuntu must have told you to reboot, and thus ParaView stopped working :(

If my deduction is correct, then you can:
  1. Run Synaptic (System->Administration->Synaptic Package Manager);
  2. Type your graphics card GPU maker (NVidia, ATI) in the search box;
  3. There should be a version of the drivers already installed - click on it for selecting it in the list;
  4. Then go to Synaptics menu: Package->Force Version
  5. Then choose the previous version.
In case your graphics card GPU is Intel, or if you can't figure out which version is being used, then go to the menu: System->Administration->Hardware Drivers. There it should tell you which the name or description of the installed drivers.

There is also the possibility that before you rebooted, you actually told Ubuntu to install the graphics card drivers, thus making ParaView to malfunction.

There is yet another possibility: if visual effects have been turned on, then turn them off again. Right click on the Ubuntu desktop, "Change Desktop Background" and on the last tab named "Visual Effects", select "None".

Finally, if neither one of these worked, then uninstall paraview380:

sudo apt-get remove paraview380
Then download the official pre-built version of ParaView 3.8.0 from Unpack it wherever you want to.
Then go to your tutorial case in a terminal and run:

touch case.foam
Now run the unpacked ParaView on another terminal or from Nautilus and open the file case.foam you just created before. If it works well, then follow these instructions to make it the standard ParaView to be used by paraFoam:
  1. OF 1.7 installation problem "command not found error" - post #8
  2. OF 1.7 installation problem "command not found error" - post #11

If opening with the official pre-built ParaView 3.8.0 + case.foam didn't work, then there is the final solution - install Ubuntu's ParaView 3.4.0:

sudo apt-get install paraview
Then in your tutorial case, you cannot use anymore paraFoam, you will have to use the following commands:


And open the files that are now available inside the new folder VTK. If this works, and you want a quicker way to run this, then here is a script that does this for you:

Best regards,

claudia.h July 21, 2010 09:42

problems with paraView
Hi Bruno,

due to paraView and the new installation of openFoam 1.7 (i am using Ubuntu 10.04 LTS) i have the problem that paraView could open the geometry but it shows "anything" that means it shows a the geometrie itselfs but the grid is very big and nearly the same in any geometry i opend. If i open the same case on a computer where i installed openFoam 1.6.x and paraView 3.6.1 the grid is okay. Maybe you have an idea how to solve this problem. Thanks!

Best regards,

wyldckat July 21, 2010 09:47

Greetings Claudia and welcome to the forum!

I'm going to have to recycle a recent post of mine - the solution for your problem should be here:

Best regards,

claudia.h July 21, 2010 12:43

Hi Bruno,
thanks a lot for your fast answer, now paraView works!

Regards, Claudia

fsalvucci July 30, 2010 15:39

I want to thank you very much, thanks to your answer now paraFoam works good in my new computer!!!! Thanks!!

All times are GMT -4. The time now is 23:55.