CFD Online Discussion Forums

CFD Online Discussion Forums (
-   OpenFOAM (
-   -   How to speed up reconstructPar ? (

NorbertB July 12, 2010 05:47

How to speed up reconstructPar ?
Hi Foamers !

I run a LES case with 32 processors, no problem (at present ^^), it took only 5hours, but the reconstruction is incredibly slow : around 80hours !

I only use 1 processor for the reconstruction (it seems logical for me), and anyway there is no -parallel option for reconstructPar.

Does anyone know how to increase the speed of that reconstruction ?
It is quite annoying to be able to run a super fast LES whereas you need 20 more times to reconstruct the case ^^


wyldckat July 12, 2010 06:29

Greetings NorbertB,

How long did it take to run decomposePar? And is there any particular reason why you need to reconstruct the case?

Is it just because you need to post-process? If so, then try using ParaView 3.8 and open the case with a file "case.foam" instead of "case.OpenFOAM"! And if it works well, and you want to use paraFoam to start using 3.8.0, then follow these instructions (2nd part of the post):

Best regards,

NorbertB July 12, 2010 06:44

Hi Bruno,

Indeed I need to post-process and thus to reconstruct the case.
It took about 20min to run decomposePar, that is quite reasonable.

If I try to use ParaView before reconstructing the fields, it will show me only one processor result or the full field result ?
I am confused : you say I don't need to reconstruct the case to post-process it ?

Best regards,


wyldckat July 12, 2010 07:02

1 Attachment(s)
:eek: 20min to 80 hours... wait, did you reconstruct all of the time snapshots? Because in theory, it should take something like "20min * ratio of total number of fields by number of initial fields * the number of time snapshots" to reconstruct!
You can try running:

reconstructPar -latestTime
This way you'll only reconstruct the latest time snapshot!

Ah and here you go, attached is the proof that you can process a decomposed case with ParaView 3.8.0 :) As long as you open with case.foam and not case.OpenFOAM, it will work :)
It's the motorBike tutorial case, which I ran with 2 processors, all in Windows! :D

Best regards,

NorbertB July 12, 2010 07:48

Ahaha, indeed I reconstructed all snapshots but ideally I would like to see the transition state and not only the final state :(
But I think I don't have the choice :)

Thank you for your time and your final proof ! I don't have root access on my computer so at present I can't use 3.8 version (using 3.6 version), but it seems very useful.

Thanks again !

wyldckat July 12, 2010 07:50

Root access? Just download the pre-built versions from and unpack in your home/user folder and use it :D That's why I gave you the link to the other post!

vishal October 21, 2010 10:29

Hi ,

I am using OF-1.7.1 and i made the change in parafoam file as u mentioned before but i am still not getting .foam file in case dir. however it used to be generate in .OpenFOAM for openfoam 1.6.0

can you please tell me how to generate .foam file

wyldckat October 21, 2010 13:49

Greetings Vishal,

There is more than one ".OpenFOAM" in the paraFoam script ;) You'll have to change them all!

edit: Then use:

paraFoam -touch
to generate the ".foam" file, but only if you intend to open it from another ParaView, instead of using paraFoam to open it directly in ParaView.

Best regards,

val46 October 22, 2010 02:44

Aaahhh... and I always thought for post-proc you have to reconstruct the case.
Thanks, Bruno!

I just saw you posted a picture of the motorbike tutorial. I know its not the topic of this thread but I would like to ask if you run this case with OF 1.7.x
Because I have convergence problems when I run this tutorial as it is.


vishal October 22, 2010 08:35


Thanks Bruon.....!!! actually i converted them all :P and its working for me. But ur comment is always usefull. so now there in no more need to change format to VTK.

just use touch and its ready for paraview. yes i am using compiled version of paraview i got with OF- 1.7.1.

no parafoam for me.... :(

does anyone know how to install qmake for CENTOS........???

val46 October 22, 2010 08:59

hm... when I use

paraFoam - touch
I get a .OpenFOAM file.

How do I get a .foam file?

wyldckat October 22, 2010 11:11

Hi val46,


Originally Posted by
open the file "$WM_PROJECT_DIR/bin/paraFoam" in your favorite simple text editor and replace every entry ".OpenFOAM" with ".foam". Now save and close the file.

edit: wow, I didn't see that there were so many posts... OK:
  • Toni: the motorBike case converged for me with OpenFOAM 1.6.x. I haven't tried running the 1.7.x yet, so I don't know if it will converge or not :(
  • Vishal: OpenFOAM-1.7.0 for CentOS/RHEL/SL 5.x 64bit released - You can snatch the Third Party applications already built for CentOS from that tutorial/script :)

Best regards,

vishal October 25, 2010 05:12

Thanks was helpful....!!!

Arnoldinho October 26, 2010 11:16

Hi all,

I found your post and find it very useful, as I have also always reconstructed the case for post processing before.

Following the simple instructions, I changed every .OpenFOAM entry to .foam in the paraFoam file. Nevertheless, when I type 'paraFoam' in the case folder (with folders 0, constant, system, processor0 - 15), ParaView displays only the initial state, i.e. the '0' folder. A 'paraFoam -touch' creates an empty case.foam file.

I use OpenFOAM 1.7.1 and ParaView 3.8.0 (from the openfoam website).

vishal October 26, 2010 14:07


Exactly you have to create .foam file open it in paraview and the you can post process it as you want. I am using same version as you and its working fine.

Arnoldinho October 26, 2010 16:29

Ok, but again: An empty .foam file is created. When opening the case in Paraview (either per paraFoam or directly within a new instance of ParaView), only the first time step is diplayed, and not the ones that are stored in the processor-subfolders :confused:.

wyldckat October 26, 2010 18:17

1 Attachment(s)
Greetings Arne,

Originally Posted by Arnoldinho (Post 280863)
Ok, but again: An empty .foam file is created. When opening the case in Paraview (either per paraFoam or directly within a new instance of ParaView), only the first time step is diplayed, and not the ones that are stored in the processor-subfolders :confused:.

Since a picture is worth a thousand or so words, here is one attached.
Notice the area where the mouse pointer is and the red line it points to? There you can change from "reconstructed" to "decomposed". Then don't forget to press the "Apply" button! ;)

Best regards,

Arnoldinho October 27, 2010 01:55

Thanks Bruno,

that looks nice. It works! I always looked for the error at the side of OpenFoam, not within Paraview itself. Maybe I should have a closer look at the manual...

Regards, Arne

val46 October 27, 2010 10:27

1 Attachment(s)
Hi Bruno,

again off-topic:
I tried the motorbike tutorial with 1.6.x and got no nice convergence (see attached picture).
Have you started it out of the box?


wyldckat October 27, 2010 20:03

1 Attachment(s)
Hi Toni,

I've never worried too much about the motorBike case fully converging. I just didn't want it to diverge, which happened with the 1.6 version.

Attached is the log.simpleFoam for a run with 1.7.1, both case and applications. I didn't have my cheat-sheet with me for plotting the residuals, so the log will have to do :)

So, by what I can see:
  1. The default number of iterations should still be 500, although I haven't check the latest git version to confirm.
  2. These logged residuals seem to be similar to the ones from your plot.
  3. The case could use some 100 or 200 more iterations, for it to fully converge, but I believe that these results should already be good. But I'm not a CFD specialist, so it's only a hunch ;)
  4. I think this case serves only as a tutorial... I don't think that it's a 100% perfected case yet, since the STL has some holes in its surface... which allows for air to go through some strange places into the hollowed bike... at least last time I inspected it, about 10 months ago :D
Best regards,

All times are GMT -4. The time now is 10:46.