CFD Online Discussion Forums

CFD Online Discussion Forums (https://www.cfd-online.com/Forums/)
-   OpenFOAM (https://www.cfd-online.com/Forums/openfoam/)
-   -   Lift&Drag Coefficients is not accurate enough! (https://www.cfd-online.com/Forums/openfoam/78905-lift-drag-coefficients-not-accurate-enough.html)

aut_iut August 5, 2010 09:41

Lift&Drag Coefficients is not accurate enough!
 
Dear Foamers,

I'm working on a fixed/moving cylinder case. I used icoFoam solver for Re<300 and results are acceptable.
When Re exceed from 300 the drag coefficients become different from literature data. I'm using pisoFoam (with LES or RAS turbulence models) solver. For example for Re=500, experimental results say that avaraged drag coefficient should be 1.18, while OpenFoam calculates it in the range of 1.35-1.5 (depending on the changing parameters like BC and initial conditions).
I supposed maybe it is because of 3D effect. So I implemented the simulation for a 3D case. But still there is a considerable difference between my results and papers one.
I'm wondering if one could suggest me how to fix this problem.
Isn't it solver errors? To be honest I'm thinking about the accuracy of pisoFoam solver.
Regards,
Rasoul

niklas August 5, 2010 10:05

and grid dependency?

aut_iut August 5, 2010 10:13

Yes, of course!
My initial grid is fine and refining the mesh just increases the solution time without any considerable improve to results.
I also changed the divScheme in fvScheme file.


All times are GMT -4. The time now is 21:55.