CFD Online Discussion Forums

CFD Online Discussion Forums (
-   OpenFOAM (
-   -   Problem with file (

WolfgangS. November 19, 2010 08:25

Problem with file
hi foamers!

I created a flow over a circular cylinder with snappyHexMesh. The blockMesh and snapyyHexMesh works, but if i run it with simpleFoam, there following error appears.

Create mesh for time = 3

Reading transportProperties

Reading field p

cannot open file

file: .../20101118_Zylinder_snappy/3/p at line 0.

From function regIOobject::readStream()
in file db/regIOobject/regIOobjectRead.C at line 62.

FOAM exiting

Yea.. there is no p file. I'm not very experienced in OpenFoam (4Weeks) or in programming. Where i can find the mistake, i do not know. :(

If i run the same with Windows:

Cannot find file "" in directory "constant/triSurface"

From function Time: findInstance(const fileName&, const word&, constIOobject::readOption)
in file db/Time/findInstance.C at line 148.
FOAM parallel run exiting

To me it seems like, it can not find the *.stl file... ??:confused: But in Linux with paraView i can see cylinder *.stl file.

Very frustrating!

Hope you can help me!

best regards

novyno November 19, 2010 11:40

Try -overwrite flag
Hi WolfgangS,

snappyHexMesh writes the intermediates steps of the mesh generation and writes the final mesh into "3" subdirectory. In your controDict you probably have the setting "startFrom latestTime". So when you run simleFoam it tries to start from "3" subdirectory where it finds the mesh but doesn't find the data (in this case p).

Delete "1", "2" and "3" folders and try to run "snappyHexMesh -overwrite". In this case snappyHexMesh writes the mesh in the standard constant directory and probably all will go fine! :-)

WolfgangS. November 22, 2010 05:52

hi novyno!

Thanks for your quick reply.
I have found my probleme with the start.cmd. It is a little bit irritating.
Regular all simulations run with 12 processors parallel. In my case (cylinder) the snappyHexMesh doesn't. I tried the snappyHexMesh with one processor and it works know. :confused: funny!

best regards

All times are GMT -4. The time now is 18:29.