CFD Online Discussion Forums

CFD Online Discussion Forums (
-   OpenFOAM (
-   -   paraview stoped working (

Benjy November 27, 2010 08:22

paraview stoped working
Hi there,

After copying and recompiling the IcoFoam to my_icoFoam as directed in the OpenFOAM wiki "how to add Temperature to icoFoam" tutorial, the new solver runned successfully.
But unfortunately, running the paraFoam gives the following error:

benjy@benjy-laptop:~/OpenFOAM/benjy-1.7.1/run/my_icoFoam_cavity$ paraFoam
created temporary 'my_icoFoam_cavity.OpenFOAM'
/opt/openfoam171/bin/paraFoam: 142: paraview: not found
benjy@benjy-laptop:~/OpenFOAM/benjy-1.7.1/run/my_icoFoam_cavity$ ^C

The paraview does not also work when i try to run other cases from the tutorials.
I am new user of OpenFOAM and don't know what next to do.

Could anyone be of help to me in solving this problem?

wyldckat November 27, 2010 08:36

Greetings Benjamin,

You are not alone on this ;) a solution already exists:

Best regards and good luck!

Benjy November 27, 2010 09:36

Hi Bruno,

million thanks for the help, it works now. But i get the following warning:

OpenGL Warning: Failed to connect to host. Make sure 3D acceleration is enabled for this VM.


wyldckat November 28, 2010 10:23

Hi Benjamin,


Originally Posted by Benjy (Post 284985)
OpenGL Warning: Failed to connect to host. Make sure 3D acceleration is enabled for this VM.

Mmm... let me guess: you are using Ubuntu in a VirtualBox virtual machine? There should be an option in the virtual machine settings, for turning on 3D acceleration, although my experience with this has never been very good (but I only tried it in VMPlayer).

But if you are using Ubuntu in a real machine (i.e., not in a virtual machine), then you haven't installed the graphic card drivers.

Best regards,

Benjy November 28, 2010 20:57

Hi Bruno,

You are right. i am using ubuntu in a vitualbox VM and have turned the 3D acceleration ON and it works now perfectly.

Thanks for the efforts.


All times are GMT -4. The time now is 22:06.