CFD Online Discussion Forums

CFD Online Discussion Forums (
-   OpenFOAM (
-   -   Boussinesq Tutorials (

cbritan December 7, 2010 01:49

Boussinesq Tutorials
I tried running the various Boussinesq tutorials (both the steady and unsteady tutorials) in OpenFOAM1.7.1 by typing ./Allrun in the directories, but I get the following error in the log file:

HTML Code:

Reading field kappat

cannot open file

file: /home/control/OpenFOAM/control-1.7.1/run/tutorials/heatTransfer/buoyantBoussinesqSimpleFoam/iglooWithFridges/0/kappat at line 0.

    From function regIOobject::readStream()
    in file db/regIOobject/regIOobjectRead.C at line 61.

FOAM exiting

Is there something in the tutorial that I am supposed to change before I run it? :confused:

cbritan December 12, 2010 22:57

No Kappat File in 0 directory
Problem is resolved. Somehow the kappat file was not in the 0 directory. I recopied the tutorials from the opt directory to my home directory and that solved the problem. It is strange that the kappat file was not copied originally...


All times are GMT -4. The time now is 04:34.