CFD Online Discussion Forums

CFD Online Discussion Forums (https://www.cfd-online.com/Forums/)
-   OpenFOAM (https://www.cfd-online.com/Forums/openfoam/)
-   -   parallel processing (https://www.cfd-online.com/Forums/openfoam/82865-parallel-processing.html)

gandesk December 8, 2010 01:10

parallel processing
 
1 Attachment(s)
Hello

I am new to OpenFOAM and want to run a case in parallel at an high performance cluster. I am able to run the same case on a single node without any hassle but, I am getting the following error attached in the logfile when I run it parallelly.

Any help would be appreciated!!


Sandeep

MartinB December 8, 2010 02:37

Hi Sandeep,

the error log mentions:
Code:

...environment variable MPI_BUFFER_SIZE not defined...
This might be a good point to start with...

Martin

gandesk December 8, 2010 11:17

further doubts
 
1 Attachment(s)
Quote:

Originally Posted by MartinB (Post 286465)
Hi Sandeep,

the error log mentions:
Code:

...environment variable MPI_BUFFER_SIZE not defined...
This might be a good point to start with...

Martin


thanks martin for your reply......
as am new to parallel processing, i did not understant what MPI_BUFFER_SIZE is...could you send me any other information .....

Actually i am doing my parallel job on a high performance computers on a super computer cluster....now I am including my qsub file also as i am expecting the possible error could be with defining the type of parallel messeging.....

thekay December 8, 2010 11:23

In the file you qsub, make sure you set up an adequate buffer size for the mpi, before you execute the solver command. Something like this is what I use:

Code:

MPI_BUFFER_SIZE=2000000000
and after that mpirun -np 64 etc.

Cheers

Edit: By the way, I think openFOAM must use openmpi and not the intel version you set.
Edit2: And something else: you seem to use 32 processor cores in your qsub file
Code:

#PBS -l nodes=16:ppn=2
yet you decompose into 64.

gandesk December 8, 2010 23:12

2 Attachment(s)
Quote:

Originally Posted by thekay (Post 286543)
In the file you qsub, make sure you set up an adequate buffer size for the mpi, before you execute the solver command. Something like this is what I use:

Code:

MPI_BUFFER_SIZE=2000000000
and after that mpirun -np 64 etc.

Cheers

Edit: By the way, I think openFOAM must use openmpi and not the intel version you set.
Edit2: And something else: you seem to use 32 processor cores in your qsub file
Code:

#PBS -l nodes=16:ppn=2
yet you decompose into 64.


Hi Costas,

I am getting the same error message even when i included MPI_BUFFER_SIZE before solver command.

And yeah I got the same message after correcting my qsub file

with openmpi the cluster is not recognizing the command.

I am including my log and qsub file for 4 processors once again after your suggestions were implimented

MartinB December 9, 2010 03:26

Hi Sandeep,
I suppose you must use
export MPI_BUFFER_SIZE=2000000000
in the qsub file.

Martin

thekay December 9, 2010 08:06

Yes, I think export is right, instead of just setting the value.

gandesk December 9, 2010 12:02

thanq guys....it seems to be working now!!

gandesk December 9, 2010 18:32

Quote:

Originally Posted by gandesk (Post 286724)
thanq guys....it seems to be working now!!


Hi,

i have got a new problem again....thanks that you have helped me running the job....now the problem is that my job is getting terminated suddenly and restarting again and again which is eventually terminating. I have included the log file in which if you see line 541 and line 3021 look similar........


I am sending the file as html file as i cnnot send more than 100 kb file
http://homepages.uc.edu/~gandesk/log

Can u help me guys...


All times are GMT -4. The time now is 09:39.