CFD Online Discussion Forums

CFD Online Discussion Forums (
-   OpenFOAM (
-   -   paraview does not work on ubuntu 10.10 maverick (

sebonator December 12, 2010 18:11

paraview does not work on ubuntu 10.10 maverick
Hi Foamers,

I just installed the newest precompiled ubuntu/debian versions of OpenFOAM and paraview from

After that i treid to test the installation as usual by running the icoFoam/cavity tutorial. blockMesh and icoFoam run well, so I think OpenFoam ist correctly installed. But when I try to start paraview by typing paraFoam, I receive a segmentation fault:

sebastian@sebastian-ThinkPad-T500:~/OpenFOAM/sebastian-1.7.1/run/tutorials/incompressible/icoFoam/cavity$ paraFoam
created temporary 'cavity.OpenFOAM'
Segmentation fault

The paraFoam -touch command also works well, so I think there really is a problem with paraview. I am using ubuntu 10.10 maverick and as I said above, I installed the precompiled versions for ubuntu 10.10 maverick directly by following the instructions on this site:

Has anybody had this kind of problem, too, and can tell me how to fix it? Does maybe even someone from OpenCFD know about this problem?

Thanks a lot in advance,
Greetings Sebastian

wyldckat December 12, 2010 19:58

Greetings Sebastian,

Mmm, two possibilities come to mind:
  1. Your graphic card drivers aren't properly installed, or the latest version of the drivers has some issues with ParaView.
  2. You have the "Visual Effects" activated. Last time I tried (a long time ago), things didn't go so well with ParaView.
Try running paraview instead of paraFoam. If it still crashes, comment the line you added to "~/.bashrc", start a new terminal, go to where ParaView is installed and run paraview from there:

cd /opt/paraview381/bin

If this way it doesn't crash, then it's an issue with the official PV3FoamReader plug-in.

Yet another possibility, which only applies if you brought your "/home/username" folder with you from another Linux installation. If this is the case, then it's the ParaView ini file that needs to be erased.

If it still crashes, uninstall OpenCFD's version and install Ubuntu's ParaView version. Then follow the instructions from point 7 from my blog post: Using the official pre-built ParaView 3.8.0 version with OpenFOAM...

Best regards,

sebonator December 18, 2010 11:33

Problem solved!
Hi Bruno,

thanks for your reply! Your first guess was right, this was a problem related to my graphics driver. My visual effects were not activated, because the lack of driver forced me to keep them switched off.

It took me a while to figure out what the problem is an in fact I only resolved the problem with some luck: While trying to install a driver for my graphic card (I tried that several times from different sources: ubuntu, ATI, lenovo...) I had to edit the file

PHP Code:


several times. One of those times I must have made a mistake, well anyhow ubuntu did not boot anymore, not even in secure mode. So I took a Live-CD and bootet a live system and used this live system to delete the

PHP Code:


file without replacing it. After that, my ubuntu booted again and suddenly I was able to activate the visual effects (this was never possible before!) and start paraview as I am used to.

So you see, I actually don't know where the problem was, because there still is no driver installed for my graphic card, but it seems as if ubuntu loaded something like a standard driver after deleting the above mentioned file and this driver does everything I want him to :).

So the problem is solved, thanks for your post, Bruno!
Greetings Sebastian

All times are GMT -4. The time now is 03:33.