CFD Online Discussion Forums

CFD Online Discussion Forums (
-   OpenFOAM (
-   -   Problem with 3rd Party SW installation (

klausb January 2, 2011 16:45

Problem with 3rd Party SW installation

I keep getting an error when installing the OpenFoam from source. The foamInstallationTest shows the following error:

... Third party software
Software Version Location
gcc 4.4.5 /usr/bin/gcc
gzip 1.3.12 /bin/gzip
tar 1.23 /bin/tar
WARNING: Conflicting installations:
OpenFOAM settings : /home/simulation/OpenFOAM/OpenFOAM-1.7.1/applications/bin/linux64GccDPOpt/icoFoam
current path :

I searched for a fix on the internet and found the following (useless) information:

In $WM_DIR/rules/linux64Gcc/c++, change LINKEXE to this:

LINKEXE = $(CC) $(c++FLAGS) -Xlinker --add-needed

Unfortunately this doesn't solve the problem.

How can I fix the problem?

wyldckat January 2, 2011 19:14

Greetings Klaus and welcome back to the forum! I just saw that the last time you posted was in 2007!

OK, you gave very little information for us to infer what was the problem. The actual error isn't related to Third Party software but in fact due to OpenFOAM itself not compiling with success.

I can only assume that you are trying to install OpenFOAM 1.7.1 in Fedora 13 or 14 x86_64. Under this assumption, I suggest that you read these two threads:
I suggest reading them thoroughly because multiple problems and respective solutions are posted in those threads!

If you still have problems compiling OpenFOAM, please run Allwmake in OpenFOAM's project folder like this:

./Allwmake > make.log 2>&1
tar -czf make.log.tar.gz make.log

Then attach the make.log.tar.gz file to your next post!

Best regards,

klausb January 4, 2011 04:43

It finally worked!

after installing some additional packages mentioned in a number of posts on the web, the installation worked.

Anyway thank you for the help offered!

All times are GMT -4. The time now is 15:22.