CFD Online Discussion Forums

CFD Online Discussion Forums (
-   OpenFOAM (
-   -   MRFSimpleFoam testing (

vaina74 January 12, 2011 07:28

MRFSimpleFoam testing
Hi everybody.
Sorry for my ignorance in linux and programming. I installed OpenFOAM-1.5-dev from CAE Team PPA (I followed openfoamwiki instructions) and now I'm trying to run this MRFSimpleFoam tutorial. If I run the case with MRFSimpleFoam I obtain the message:

MRFSimpleFoam: command not found
What am I wrong with? Have I to build something?

tcarrigan January 12, 2011 19:54

Both MRFSimpleFoam and simpleSRFFoam have to be built from source. I don't know why this is, but it's pretty easy.

- Navigate to the tutorials directory
- Find MRFSimpleFoam
- The source is inside the MRFSimpleFoam tutorial directory
- Run wmake, and you're done!
- Do the same for simpleSRFFoam

vaina74 January 13, 2011 03:09

thanks for your explanations, tcarrigan.
I looked for the folder and I found /usr/share/doc/openfoam-dev-1.5/examples/MRFSimpleFoam/MRFSimpleFoam. It contains a subdirectory Make (with files and options files) and two files: MRFSimpleFoam.C and createFields.H. I tried wmake but it fails (not found). Maybe I have to run make? I use Ubuntu 10.04 64-bit.
[I move this thread to Installation section, you defined my problem]

All times are GMT -4. The time now is 23:36.