CFD Online Discussion Forums

CFD Online Discussion Forums (
-   OpenFOAM (
-   -   snappyhexmesh problem (

owayz February 1, 2011 09:14

snappyhexmesh problem
Hi all,
I am a realtively new user of snappyhexmesh. I was trying to adapt the motorbike tutorial for my own problem, to use snappyhexmesh. But it seems to give an error which i cannot understand.
----------------------------------------------from terminal---------------------------------------
Create time

Create mesh for time = 0

Read mesh in = 0.26 s

cannot open file

file: /home/users/ali/crucible/crucible01/system/decomposeParDict at line 0.

From function regIOobject::readStream()
in file db/regIOobject/regIOobjectRead.C at line 62.

FOAM exiting

any help idea or source would be of great value to me.

DanielPT February 1, 2011 10:23


did you edited something in your decomposeParDict? I never had a problem like this.


owayz February 1, 2011 11:03

I am a new user, so I have no idea what dict is it. I havent modified anything. I just tried to do the simple thing. By running blockMesh first and then to refine and snap, I tried to use the snappy hex mesh.
I have also attached my snappyHexMesh dict.

DanielPT February 1, 2011 11:20

Hello again,

ok please look in your systems folder. Is there a decomposeParDict inside? When not, copy it from a tutorial.

I attached two useful tutorials for snappyHexMesh.

owayz February 2, 2011 08:29

hi and thanks
Hi Daniel Thanks for zour help, yes I coped that file from the tutorial and now atleat its trying to do something. But I have an error.
First I will explain my problem:
My problem is not very difficult. I have a half sphere for which I have to creat an internal mesh. My surface is in stl format. I create a rectangular box completely enclosing the sphere. I specify the locationinmesh to be a point inside the half sphere. And I was expecting to to get refinement and snapping at surfaces. Thanks for the tutorials, I have seen them already before, but don't know whz i didn't find them very helpful.
I have attached a file that contains the log from terminal, please have a look at it and tell me the possible reasons of the behavior. :confused:

owayz February 2, 2011 08:33

1 Attachment(s)
Sorry there was some problem the file was not attached.
Here is the file again.

DanielPT February 2, 2011 13:16


your log file tells me, that expansionRatio isn't definded in snappyHexMeshDict .
Look in the addLayer part. Maybe you have forgotten a semicolon or the whole entry.


All times are GMT -4. The time now is 12:33.