CFD Online Discussion Forums

CFD Online Discussion Forums (
-   OpenFOAM (
-   -   About the use of software FOAM (

Li Yang January 9, 2005 07:41

About the use of software FOAM
Hello all,

I am thinking to start to have a try on the software FOAM from the OpenFOAM web.

I downloaded OpenFOAM-1.0.General.gtgz from Other platforms ( and also from Sun Ultrasparc Solaris )since I have only got access to a Sun Solaris workstation(32bit). Unfortunately, I failed to decompress the file.

I tried the following options: tar -xvf OpenFOAM-1.0.General.gtgz

This gives me the error massage: tar: directory checksum error

Then I try to follow the instructions given by the OpenFOAM web, I use: tar xzf OpenFOAM-1.0.General.gtgz

This gives the following error message: tar: z: unknown option

Could anybody out there tell me what mistake I have made or what I should do please ? Thank you very much in adavnce.

Yours sincerely,


Jonas Larsson January 9, 2005 09:21

Re: About the use of software FOAM
try renaming the file to OpenFOAM-1.0.General.tar.gz

then do "gunzip OpenFOAM-1.0.General.tar.gz"

then do "tar -xfv OpenFOAM-1.0.General.tar"

hope that helps

Li Yang January 9, 2005 11:12

Re: About the use of software FOAM

Thank you very much.

It does work better. However, a error message appears at a certain stage:

OpenFOAM-1.0/doc/Doxygen/html/d0/d14/cellDecompCuts_8H-source.html, 13860 bytes, 28 tape blocks

tar: directory checksum error

Now I have got two directories :



under \doc I can see three sub-directories:




But I cannot see any Fortran source file. Why?

Your help will be very much appreciated.


Praveen C January 9, 2005 11:35

Re: About the use of software FOAM
Download the file again from the openfoam website and try it.

Jonas Larsson January 9, 2005 17:56

Re: About the use of software FOAM
That is strange. If the gunzip worked I would expect the tar to work also. A download error would break the gunzip not the tar. Perhaps your disk is full so that your tar file got truncated?

matej January 10, 2005 04:22

Re: About the use of software FOAM
However, even if you untar succesfully, you'd never see any fortran in foam, as it is written in C++ :o))


jf January 10, 2005 18:12

Re: About the use of software FOAM
Is gnu tar available on (your) Solaris ? If yes, try running "gtar xzvf OpenFOAM-1.0.General.gtgz". The problem is perhaps due to a mismatch between tar versions.

Hrvoje Jasak January 12, 2005 17:12

Re: About the use of software FOAM
Yup, you need gnu tar - the one from Solaris has got hard-coded max path length and the directory structure of foam is too deep for foam.


ollickle May 16, 2009 00:28

similar with ThirdParty.General.gtgz
Using Fedora,latest, changed OpenFOAM-1.5.General.gtgz to.tar.gz and
did tar xzf - all went well.
Same thing with ThirdParty.General.gtgz no good
tried gunzip no good.

So this file is neither tar nor gzip.

Excuse fumbles, am new at this Linux, just need it for real work!


ollickle November 2, 2009 23:59

OpenFOAM Ubuntu Installation
Changed from Fedora to try installation in Ubuntu 9.04,
need install instructions that work... please

All times are GMT -4. The time now is 04:39.