CFD Online Discussion Forums

CFD Online Discussion Forums (https://www.cfd-online.com/Forums/)
-   OpenFOAM (https://www.cfd-online.com/Forums/openfoam/)
-   -   From function specieThermo<thermo>::T(scalar f, scalar T0, scalar ... Error (https://www.cfd-online.com/Forums/openfoam/85247-function-speciethermo-thermo-t-scalar-f-scalar-t0-scalar-error.html)

abminternet February 21, 2011 08:24

From function specieThermo<thermo>::T(scalar f, scalar T0, scalar ... Error
 
Hi foamers,

Has anyone encountered this error before and succesfully solved it??

From function specieThermo<thermo>::T(scalar f, scalar T0, scalar (specieThermo<thermo>::*F)(const scalar) const, scalar (specieThermo<thermo>::*dFdT)(const scalar) const) const
in file /opt/software/openfoam/extend/OpenFOAM-1.6-ext/src/thermophysicalModels/specie/lnInclude/specieThermoI.H at line 73
Maximum number of iterations exceeded. Rescue by HJ

I am getting it in two different cases, one steady state and one transient. I have read some threads and they say lowering some relaxation factors could solve it, so I tried it for the steady state case, and it just goes on for a couple more iterations but then it fails again. For the transient case I get it once and the solver stops. Any suggestions??? Thanks in advance.

masuarez March 8, 2011 14:41

I have the same problem... i'm using chtMultiRegionFoam. If you find out anything, please let me know. I'll keep looking and see what I can find out.

Miguel

PeterBishop March 29, 2012 04:57

I'm experiencing the same problem, any news?

Farshad_Noravesh December 12, 2012 02:30

Maximum number of iterations exceeded
 
Hi,

I have the same problem in rhoCentralFoam.

Farshad

kalle December 12, 2012 05:34

This thread may provide solution(s):

http://www.cfd-online.com/Forums/ope...ombustion.html

If specieThermo cannot invert h(T) to give T iteratively, usually two things can be wron: Either is the h(T) function erroneous, like in the thread above, or your enthalpy equation is diverging in your solver, giving extreme values of h. In the former case, review the thermo input data. In the latter case, you should investigate why you get such values for h.

K

hz283 December 15, 2012 15:50

Hi,

I also had this problem last week. The density is negative, which may be caused by wrong calculation of pressure or enthalpy (energy). But I think the true reason is diverse and case by case. For my simulation, I modified the mesh (remove some cell of bad quality), and the simulation seems good now. Maybe this issue can be caused by not suitable BC specification, and so on.


All times are GMT -4. The time now is 15:17.