CFD Online Discussion Forums

CFD Online Discussion Forums (
-   OpenFOAM (
-   -   HOWTO fix mpirun problem (

JunaidAhmad April 28, 2011 10:21

HOWTO fix mpirun problem

i am trying to run OF on multi computers [ip's: and]
now when i run command

mpirun --hostfile mechine -np 4 simpleFoam -parallel > log

openfoam@'s password:
mpirun was unable to launch the specified application as it could not find an executable:

Executable: simpleFoam

while attempting to start process rank 2.

So please someone tell me what to do.

I am using Ubuntu 10.10.

longamon April 28, 2011 11:00

try :mpirun -np 4 --hostfile [hostfilename] simpleFoam -parallel > log

also try: foamJob -p simpleFoam with the machines file in the system folder

make sure all nodes have openFoam or can access OF functions. It could be your slave node hasn't OF installed.

see this for more info:

JunaidAhmad April 29, 2011 01:24

Thank You
Thanks a lot............................................... are a life saver

JunaidAhmad April 29, 2011 13:21

i add [source /opt/openfoam171/etc/bashrc]
in the first line of these files
sudo gedit ~/.Profile and gedit ~/.Bashrc
and it worked
SO if anyone have that kind of message then copy and paste the above line

All times are GMT -4. The time now is 19:31.