CFD Online Discussion Forums

CFD Online Discussion Forums (
-   OpenFOAM (
-   -   Surface Roughness (

Jochem July 6, 2011 04:16

Surface Roughness
1 Attachment(s)

I am trying to simulate windflow over a flat plane. In this case I am trying to have the same windprofile at the inlet and the outlet.

For the inlet I am using atmBoundaryinletVelocity. I use a certain surface roughness(Z_0) for the inlet and after some trial and error this works. Then I use nutkRoughWallfunction (from turbineSiting tutorial) to apply I certain roughness to the flat plane. If I then use the same roughness as for the inlet the wind profile should be constant over the hole Case, I guess?

On the forum I found how to fill in the parameters for nutkRoughWallfunction:

Ks = 20*Z_0 and Cs = 0.327 (always)

I tried this for different roughness but I never get the same wind profile on the inlet and the outlet. Can someone tell me why? In the next figure you can see the difference between the windspeed.

Best regards,


Bernhard July 6, 2011 05:33

What kind of turbulence modelling are you using?
How does your mesh look like?
What is the boundary condition at the outlet?
What does this profile look like half-way the domain?
Is the inlet profile identical to the outlet profile for smooth walls? Or is it really the roughness that introduces the problem?

Jochem July 6, 2011 06:17

Hello Bernard,

Thanks for the quick reply.

I am using the kepsilon turbelence model with the simpleFoam solver.

For now i am just using blockMesh and apllying roughness to the ground patch. If I am able to apply different roughness, I will use snappyHexMesh. It seemed better to start with the most simple case.

The boundary at the outlet for U is inletoutlet for p is uniformfixedValue.

I also tried to plot half way the domain, but actually the wind profile starts changing from the begin of the Case, so I dont think It has something to do with a wrong boundary condition for the outlet.

I havent try to set the surface for smooth walls, I will try to do this now.

I hope you can see something is wrong with these answers, I am struggling with this problem for some time.



All times are GMT -4. The time now is 10:52.