CFD Online Discussion Forums

CFD Online Discussion Forums (
-   OpenFOAM (
-   -   anyone tried rhoPorousMRFSimpleFoam in OF 2.0.0? (

suh August 29, 2011 02:20

anyone tried rhoPorousMRFSimpleFoam in OF 2.0.0?
Hello Foamers,
I am using rhoPorousMRFSimpleFoam for compressor simulation. the mesh is came from starccm+ and checkMesh is ok. Then these are my boundary conditions. I am starting with very slow rotational velocity, i.e. w=1 rad/sec.

for p
outlet-fixedValue, $internalField
wall-zeroGradient internalField uniform 2e5;

for U
inlet-fixedValue, uniform (150 0 0)
wall-fixedValue, uniform (0 0 0) internalField uniform (1 10 10)

for T
inlet-totalTemperature, T0 uniform 300, gamma 1.4
outlet-inletOutlet, value $internalField, inletValue $internalField
wall-zeroGradient, internalField uniform 298;

for mut
inlet-calculated uniform 0,
outlet-calculated uniform 0,
wall-mutkWallFunction uniform 0, internalField uniform 0.018;

for k
inlet-fixedValue, uniform 70
wall-compressible: :kqRWallFunction uniform 7, internalField uniform 7;

for epsilon
inlet-fixedValue, uniform 19222.91
wall-compressible: :epsilonWallFunction uniform 1922.291, internalField uniform 7;

for alphat
inlet-calculated uniform 0,
outlet-calculated uniform 0,
wall-alphatWallFunction uniform 0, internalField uniform 0;

my relaxation factors from fvSolution files are
p 0.1;
rho 1; // I changed this to 0.5 then it ran for about 3500 iterations and then diverges because of thermal properties error message.
U 0.3;
"(k|epsilon)" 0.5;
h 0.5;

and rhomax - 1.9
rhomin - 0.6


thermoType hPsiThermo<pureMixture<constTransport<specieThermo <hConstThermo<perfectGas>>>>>;
nMoles 1;
molWeight 28.9;
Cp 1007;
Hf 2.544e+06;
mu 0.1835e-04;
Pr 0.72;

and I am getting this error after 200 iterations.

Maximum number of iterations exceeded

From function specieThermo<Thermo>::T(scalar f, scalar T0, scalar (specieThermo<Thermo>::*F)(const scalar) const, scalar (s pecieThermo<Thermo>::*dFdT)(const scalar) const) const
in file /opt/software/OpenFOAM/OpenFOAM-2.0.x/src/thermophysicalModels/specie/lnInclude/specieThermoI.H at line 67.
FOAM aborting
#0 Foam::error::printStack(Foam::Ostream&) in "/share/openfoam/2.0/OpenFOAM/platforms/linux64Gcc45DPOpt/lib/"
#1 Foam::error::abort() in "/share/openfoam/2.0/OpenFOAM/platforms/linux64Gcc45DPOpt/lib/"
#2 Foam::hPsiThermo<Foam::pureMixture<Foam::constTran sport<Foam::specieThermo<Foam::hConstThermo<Foam:: perfectGas> > > > >::ca lculate() in "/share/openfoam/2.0/OpenFOAM/platforms/linux64Gcc45DPOpt/lib/"
#3 Foam::hPsiThermo<Foam::pureMixture<Foam::constTran sport<Foam::specieThermo<Foam::hConstThermo<Foam:: perfectGas> > > > >::co rrect() in "/share/openfoam/2.0/OpenFOAM/platforms/linux64Gcc45DPOpt/lib/"
#4 main in "/share/openfoam/2.0/OpenFOAM/platforms/linux64Gcc45DPOpt/bin/rhoPorousMRFSimpleFoam"
#5 __libc_start_main in "/lib64/"
#6 Foam::UOPstream::write(char) in "/share/openfoam/2.0/OpenFOAM/platforms/linux64Gcc45DPOpt/bin/rhoPorousMRFSimpleFoam"

Please tell me where I am going wrong.
Is anybody using rhoPorousMRFSimpleFoam?


suh August 30, 2011 06:28

Hello Foamers,

Anybody did simulation of compressor using compressible solver of openfoam (main versions)?

I am using OF 2.0.0 and rhoPorousMRFSimpleFoam solver, but I need help to run the simulation.

If anyone has any expirience with this, please give some suggestions...

The simulation is running but there is no pressure increament. why?

Thank you.

kalyangoparaju July 19, 2012 11:16


I know this is very late but did you solve your problem. The issue can be with the porosity treatment.

I had a similar problem when I was using explicit porosity treatment for high resistance porous region. Changing it to imnkplicit did the trick.


All times are GMT -4. The time now is 20:13.