CFD Online Discussion Forums

CFD Online Discussion Forums (
-   OpenFOAM (
-   -   Trying to run a benchmark case with simpleFoam (

spsb February 24, 2012 09:24

Trying to run a benchmark case with simpleFoam
Hi, I have a OpenFOAM based benchmark that I have been asked to run. I have never before used OpenFOAM and I need some help because I'm lost.

I have been given a tar-file with "the job" containing the directories 0, contant and system). There are also an example script:


$ cat run8CPUsSequential
# Run the program
simpleFoam . . > log1_8CPUsSequential_1 &
simpleFoam . . > log1_8CPUsSequential_2 &
simpleFoam . . > log1_8CPUsSequential_3 &
simpleFoam . . > log1_8CPUsSequential_4 &
simpleFoam . . > log1_8CPUsSequential_5 &
simpleFoam . . > log1_8CPUsSequential_6 &
simpleFoam . . > log1_8CPUsSequential_7 &
simpleFoam . . > log1_8CPUsSequential_8 &


I have installed OpenFOAM on a Ubuntu system following the Ubuntu installation guide at

When i run "simpleFoam . ." I got a error.
After I read the help page ("simpleFoam -help") i re-run the command without parameters and ended up with this output.


cannot find file

file: /root/OpenFOAM/root-2.1.0/run/bench/constant/RASProperties at line 0.

    From function regIOobject::readStream()
    in file db/regIOobject/regIOobjectRead.C at line 73.

I cant find a RASProperties a file in constant. Is that a required file? I wonder because I think it's strange if they missed to supply me with that file.

For the time being I borrowed a RASProperties from one of the examples, I picked one RASModel out of random and re-run the application and ended up with this output:


keyword div((nuEff*dev(T(grad(U))))) is undefined in dictionary "/root/OpenFOAM/root-2.1.0/run/bench/system/fvSchemes::divSchemes"

file: /root/OpenFOAM/root-2.1.0/run/bench/system/fvSchemes::divSchemes from line 39 to line 46.

    From function dictionary::lookupEntry(const word&, bool, bool) const
    in file db/dictionary/dictionary.C at line 400.

I have tried to read the documentation but as expected it's written for a person who intend to write a job and run a simulation. I'm a (mostly) a sysadmin who have been asked to run a OpenFOAM-based benchmark and I'm somewhat lost :)

Anyone out there who can point me at the right direction?

Using: OpenFOAM-2.1.0 (see
Build: 2.1.0-0bc225064152

wyldckat February 24, 2012 09:49

Greetings spsb and welcome to the forum!

When they gave you this benchmark job, did they say which version of OpenFOAM the test case was meant to be run with? Because OpenFOAM keeps evolving and case files become gradually different between each version.

Either way, the file you're getting a complaint now is "system/fvSchemes". You can get the missing line from this file:

You could copy the whole file, but you'll risk triggering a bigger problem.

I found this example by running the following command:

find $FOAM_TUTORIALS -name fvSchemes | xargs grep -sl 'nuEff'
Best regards,

spsb February 24, 2012 10:00

Hi, I added


div((nuEff*dev(T(grad(U)))))    Gauss linear;
And it's working, thanks!

I will check with version the test was intended to work with. One more question, is the RASProperties-file always a required part of a job?

wyldckat February 24, 2012 10:07


Originally Posted by spsb (Post 346145)
I will check with version the test was intended to work with. One more question, is the RASProperties-file always a required part of a job?

AFAIK, Depends on the solver at hand.

All times are GMT -4. The time now is 14:15.