CFD Online Discussion Forums

CFD Online Discussion Forums (
-   ParaView (
-   -   "Integrate Variables" and "Plot Selection Over Time" fail (

haakon June 28, 2012 09:35

"Integrate Variables" and "Plot Selection Over Time" fail
1 Attachment(s)

I am using OpenFOAM 2.1.0 and Paraview 2.12.0 (RPM builds for OpenSuse) and the interFoam solver to analyze a simple two-phase problem (2D flow over spillway).

What I want is to record/plot the free surface elevation over time. That can be done with the following procedure:
  1. Plot the volume fraction alpha1 over a vertical line crossing the free surface inside the domain. This is done with the "Plot over Line" filter. No problems.
  2. Integrate the volume fraction over the line. This will give an approximation of the free surface elevation relative to the lower end of the line. This is done with the "Integrate variables" filter. No problems.
  3. Plot this integrated value over time. This can (hopefully) be done with the "Plot selection over time" filter. Here is the problem.
My problem is that I really cannot get the "Plot selection over time" filter to work. I select the row with my integrated variables, and press "copy to active selection". Then I press "Apply", but the result is lots of error messages in the terminal. See attached file "PVerrors.txt" for them all. For your reference I post one error of each type here:


Warning: In /home/preston2/mattijs/rpmbuild/BUILD/ParaView-3.12.0/VTK/Common/vtkDataArrayTemplate.txx, line 452
vtkIdTypeArray (0x81aacc0): Input and output array data types do not match.


ERROR: In /home/preston2/mattijs/rpmbuild/BUILD/ParaView-3.12.0/VTK/Filtering/vtkTable.cxx, line 353
vtkTable (0xa26faa0): Column "k" must have 1 rows, but has 901.


ERROR: In /home/preston2/mattijs/rpmbuild/BUILD/ParaView-3.12.0/VTK/Charts/vtkContext2D.cxx, line 177
vtkContext2D (0x87bf870): Attempted to paint a line with <2 points.

See also attached screenshot of my PV workspace.

Can anybody help me here? Am I doing something wrong or have I missed something fundamental?

Thank you in advance.

haakon July 9, 2012 03:09

The solution (or at least a workaround) was at last found: I had used the parallel OpenFOAM reader (reading the decomposed case directly), witch seems to be the cause of this error. If i reconstructed the previously parallel case and then used paraFoam, and suddenly everything worked.

Noraa April 20, 2015 18:22

Dear Hakon,

I am dealing with the same problem. I am using Interfoam solver for dambreak problem. I have 3D domain. I would like to to calculate the free surface time history at specific location of my domain using plot over time filter. I tried these steps but no success. It dose not show me the accurate water profile.

would you please help me with this?

thank you,

All times are GMT -4. The time now is 17:16.