CFD Online Discussion Forums

CFD Online Discussion Forums (
-   ParaView (
-   -   Legacy VTK for time dependent variables. (

Splatzo February 21, 2013 13:02

Legacy VTK for time dependent variables.
I've calculated the movement of a fluid in a porous medium by calculating its saturation change over time. I'd like to plot that in Paraview as an animation. I am running the 64 bit version 3.98.1 on Windows 7.

The grid and saturations have been written as Legacy VTK files (ASCII). The grid itself is unstructured and I've made three files each containing a duplicate of the grid (which does not change in time) and the saturation at each time step. The files are named So1.vtk, So2.vtk and So3.vtk. Each file can be loaded to Paraview independently. Paraview also sees them as a set which can all be loaded.

The problem that I have is that when all are loaded together, I only see one of the time steps as a property in the Display area. I can also see "Solid Color" and "Cell Normals". When I click on the "Play" button to then cycle through the time steps a sort of movie plays. I get the property that I can see alternating with "Solid Color".

All the forum items on this suggest that I should get an animation no problem. Could I be configuring the Legacy VTK files OK or is there a problem with Paraview or is it just not set up for what I want to do. I have tried the blood cell animation but that just changes the grid and not grid_cell properties.

I can load all three files independently and then set up each property to be displayed in time on the Animation View. I may need to play with this a bit more but it seems a bit clunky on display, I can't apply one filter to all time steps easily and I don't want to set that up for a bigger run which may have 20 time steps.

Thanks in advance,

Splatzo February 22, 2013 05:02

Problem solved!!
It came to this morning what the problem might be. In each So*.vtk file I had given the Scalar variable a different name (So1, So2 etc.). This seemed intuitively obvious from previous software packages that I've used. Turns out you should give the variable the same name at each time and that solves it.


All times are GMT -4. The time now is 11:46.