CFD Online Discussion Forums

CFD Online Discussion Forums (
-   ParaView (
-   -   EPS files in ParaView (

Yann July 9, 2013 17:29

EPS files in ParaView
Hello all,

I use ParaView 4.0.1 to post-process simulations from OpenFOAM and i'm stumbling to export eps files using the "export scene" function.

Basically, i plot a slice of velocity field and i would like to have a vectorial image of it in an eps file to use it in LaTeX.
The only thing i can get is a compressed image of the whole scene. If I choose to not rasterize 3D geometry in the export options, i get a vectorial image but the whole slice is gray and i don't see the velocity field.

Do i miss something somewhere ? Or is it just not possible to get a vectorial image of the slice ?
Does anybody has a trick to solve this problem ?


Yann July 21, 2013 06:18

Nobody else with this problem ?
Or just not any solution to have a proper export in eps file ?

wyldckat July 21, 2013 12:32

Greetings Yann,

Can you please show an example of what you are seeing in ParaView and on the EPS file?

Best regards,

Yann July 21, 2013 19:15

5 Attachment(s)
Hello Bruno,

You're right, an example is better than a long talk so, here is the thing :

On the screenshot.jpg is what i see on Paraview : a velocity field, glyphs and a colormap.
Then, I use the "export scene" function with default options and here is what i have in my eps file (eps1.jpg) : the colormap is missing and when I zoom in (eps1_zoom.jpg) the velocity field and glyph are compressed.
I give a second try and i export with the same options except that i choose to untick the "rasterize 3D geometry" option : it works better (eps2.jpg), I have the colormap, the glyphs and both are vectorial (eps2_zoom.jpg) but I've lost the color on the velocity field...

I played with the options but I can't find something working...
Any suggestion ?


wyldckat August 18, 2013 18:24

Hi Yann,

I don't know if you managed to find the solution and I don't know if you saw this other thread on nearly the same topic, that has a few possible solutions:

The options from post #2 worked well for me, although I had to first change the colours of the text for the scalar bar, otherwise the text would be white on white paper :)

Best regards,

Yann August 19, 2013 10:05

Hi Bruno,

Thanks for your reply. I tried to use your solution on the other topic but i get the same result than in the second example in my previous post: it works but i loose the color of the velocity field.
I tried to export only the slice of velocity field without glyphs but it's the same result.

I'm using ParaView 4.0.1 64bit on Windows 7 64bit.
I tried the same version of ParaView running on a virtual machine with Ubuntu 12.04 but it was worst (nothing exported except the scalar bar). I'm not so confident in this machine as it isn't a clean install but currently i haven't another machine to test it.

If it works well for you i guess the problem can only come from me or my computer...

Best regards,

wyldckat August 19, 2013 12:13

1 Attachment(s)
Hi Yann,

Well, I tested ParaView 4.0.1 64bit on a machine with Windows 7 64bit and it crashes midway of the export scene.
Apparently there is a weird issue with renaming the temporary file that it generates for the export scene, at least on my machine.

Nonetheless, when I export to PDF, the resulting PDF file is somehow damaged, but the contents seem fine, as provided in the attachment.
edit: I used the settings from the post #2 on the other thread.

Unfortunately I'm unable to figure out the problem :(

Best regards,

Yann August 19, 2013 17:24

2 Attachment(s)
Thank you Bruno for your tests!

The export seems surprisingly machine-dependant. I have no crash nor warnings in ParaView when exporting in EPS.
I also tried an export to PDF and it leads to the same problem than for EPS, as you can see in the attachment. (And the resulting PDF file seems "damaged" like your)

I have no idea about what could cause such differences as on your last test we use the same OS and same version of ParaView. :confused:
I know this function was one of the most requested features by the users, but I can't find other users dealing with the same issue on the internet.

For now I'm stuck, I'll try to export from another machine as soon as I'll have the occasion.

Best regards,

wyldckat August 20, 2013 17:52

Hi Yann,

I remembered just now to check with my test case to export the scene when representing the "point data", instead of the "cell data" that I've been using, and I got the same issue of having a grey geometry... although ParaView still crashed :(
By the way, I always used the 3D representation, but 2D mode gave the same issue.

I'll test on my home computer at the end of this week, to see if on Ubuntu I get the same issue or not... because I think I used "cell data" as well on that case.

Nonetheless, my guess is that since point data is actually a representation of interpolated results onto surfaces, it is not easily pseudo-rasterized (because we turned off the 3D raster option) by the gl2ps driver.

But still, I'll test this on my Ubuntu machine later this week.

Best regards,

Yann August 21, 2013 04:22

1 Attachment(s)
Hi Bruno,

Well done, that's it! :)
I was exporting the view from "point data" representation. It works well with the "cell data", as you can see in the attachment.

I've seen you were using "cell data" on the PDF file you've posted but I didn't realize it could be the source of the issue. You're probably right about the trouble for gl2ps to export interpolated data.
I hope this will be useful to users dealing with the same issue. Thank you for your help, I would have spent a lot of time before figuring this out on my own.

By the way, I post a PDF file but the export to EPS file works also fine for me.

Best regards,

jaibhi September 11, 2014 02:34

I am having the same issue of losing colors when unchecking the rasterize 3D geometry option.
Reading through the discussions above, it seems that the data types I am using (Point) maybe the issue. However, I am confused on how to switch between 'point data' representation and 'cell data' representation while exporting from Paraview. Can you elaborate more on this issue?

wyldckat September 13, 2014 15:34

1 Attachment(s)
Greetings jaibhi and welcome to the forum!

Originally Posted by jaibhi (Post 509921)
Can you elaborate more on this issue?

In a nutshell:
  1. I wrote a post about "point data" vs "cell data" sometime ago... it's this one: post #12
  2. You can use the filter "Point Data to Cell Data" to interpolate the values from points to the center of the cells.
  3. See the attached image, where the lines with the orange cubes are the cell data and the lines with the orange'ish dot is the point data (it's the last two lines).
Best regards,

Jibran May 5, 2015 09:55

Exporting point data in vector graphics from ParaView 4.3.1
3 Attachment(s)
Hello Everyone,

I am still facing the same problem for point data in ParaView 4.3.1. It works well for cell data as mentioned earlier. The options for exporting the scene and the results are attached.

Any information on how to export ParaView point data in vector graphics will be appreciated. Thanks!

Best Regards

wyldckat September 20, 2015 14:50

1 Attachment(s)
Greetings Jibran,

I had this on my to-do list and only today did I finally manage to look into this.
The solution has already been presented here:
Quoting the details:
  1. Disable "Interpolate Scalars Before Mapping"
  2. Set "Backface Representation" to "Cull Backface"
Both are in the "Properties -> Display" section, visible only when the advanced options are turned on, as shown in the attached image. Marked in red are the 3 controls I mentioned.

Best regards,

Sebastian Fink November 9, 2016 10:52

1 Attachment(s)

I try to export a vector graphic using binary package ParaView5.2 / 4.4 in Ubuntu 16.04.

I tried different options but just the numbers are good.
I checked the other two Threads as well but I don't what I miss.

Best regards

All times are GMT -4. The time now is 21:49.