CFD Online Discussion Forums

CFD Online Discussion Forums (
-   ParaView (
-   -   Running ParaView on multiple cores (

flotus1 December 2, 2013 06:44

Running ParaView on multiple cores
I am unable to run ParaView in parallel on one of our workstations. Running it on a single core works perfectly.

The operating system is OpenSuse 12.3.
The versions of Paraview I tried are 3.98 and 4.1 RC1.
The workstation is a 2-CPU machine with 2 Xeon E5-2687W processors, so it should be able to run applications in parallel.

When I activate the "use multi-core" option and restart PV, I get the following error messages in the command shell:

AutoMPI: SUCCESS: command is:
 "/usr/Paraview/ParaView-4.1.0-RC1-Linux-64bit/lib/paraview-4.1/mpiexec" "-np" "2" "/usr/Paraview/ParaView-4.1.0-RC1-Linux-64bit/lib/paraview-4.1/pvserver" "--server-port=40062"
AutoMPI: starting process server
-------------- server output --------------
ssh: Could not resolve hostname Name or service not known
AutoMPI: server never started.
vtkProcessModuleAutoMPIInternals: Server never started.
Generic Warning: In /home/utkarsh/Dashboards/MyTests/NightlyMaster/ParaViewSuperbuild-Release/paraview/src/paraview/ParaViewCore/ServerManager/Core/vtkSMSession.cxx, line 315
Failed to automatically launch 'pvserver' for multi-core support. Defaulting to local session.

From PV, I get the output message:

Generic Warning: In /home/utkarsh/Dashboards/MyTests/NightlyMaster/ParaViewSuperbuild-Release/paraview/src/paraview/ParaViewCore/ServerManager/Core/vtkSMSession.cxx, line 315
Failed to automatically launch 'pvserver' for multi-core support. Defaulting to local session.
Strange enough, I have no problems running the same versions of PV in parallel on a different workstation operating OpenSuse 11.4.
What can I do to get it running?

wyldckat December 8, 2013 15:23

Hi Alex,

Sorry, I was the one that had requested you to ask this here and I didn't manage to look into this sooner.

OK, lets try to diagnose this. My first guess is that your machine in question has got the host name "", but no IP is assigned to that name. To check this, run:

Use Ctrl+C to abort. To compare with something similar to what you should be seeing, run:

If it does not show a similar output, then the problem is as I guess, where there is no IP address assigned to that host name.
If this is the case, then (as root) edit the file "/etc/hosts" and add this line to the end:
Save and close the file. Then back as normal user (not as root), try running ParaView once again.

Best regards,

flotus1 December 9, 2013 03:47

Hi Bruno, thanks for your reply. I knew you did not forget about this.

Well first of all, your guess was correct. Adding the name of the system to the host list did the trick.
But I have an additional question concerning this issue.
On the other system I mentioned, the entry in /etc/hosts reads
Code: P-H-287-04.LIX
Obviously, the name of this system is "P-H-287-04.LIX". I was just wondering about the different IP-address here although localhost still has ""
Sorry if this is more of a linux question, but there are no experts at my university.

wyldckat December 9, 2013 18:49

Hi Alex,

Ah, I meant to write about that, but thought that it was too much information :)

So, the "127.0.0.*" IP addresses are usually all part of the loopback mechanism:

Therefore, you can use any or all values from 1 to 254 for the last number! At least in theory :) For example, all of these are part of the loopback system:

The ellipsis are just so that I wouldn't have the bad idea to write all of the 254 possible addresses :D

Oh, as for the names to the right of the IP address: I don't know if there is a limit, but you can write there any and all names you want to associate to said IP address, for example:
Code: home.local out.of.ideas

Best regards,

flotus1 December 11, 2013 12:12

Thank you, I really appreciate your help.

luchen2408 January 20, 2014 02:06

hello,Alex and wyldckat
I also want to parallel run paraview. I work with a server (24 cores).
I have tried some methods, but it faild.
Can you share me the detail procedures on how to running paraview on multi cores? Thanks.

flotus1 January 20, 2014 04:22

It would be better to start a new thread, even if the problem appears to be similar in the first place.
Try again and provide more information.

All times are GMT -4. The time now is 19:57.